Bug 97181 - missing BuildRequires: for gail-devel and gettext.
missing BuildRequires: for gail-devel and gettext.
Product: Red Hat Raw Hide
Classification: Retired
Component: gtkhtml2 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2003-06-11 05:54 EDT by Dams
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-11 11:37:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dams 2003-06-11 05:54:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
rpmbuild --rebuild gtkhtml3-3.0.5-2.src.rpm
checking for gail >= 0.13... Package gail was not found in the pkg-config search
Perhaps you should add the directory containing `gail.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gail' found

configure: error: Library requirements (gail >= 0.13) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a
nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.19947 (%build)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.19947 (%build)
zsh: exit 1     rpmbuild --rebuild gtkhtml3-3.0.5-2.src.rpm

BuildRequires for gail-devel is missing. And BuildRequirs gettext is missing too
: if gettext is missing translation wont be installed and %find_lang will
generate an error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. rpm -e gail-devel
2. rpmbuild --rebuild gtkhtml3-3.0.5-2.src.rpm

Additional info:

Bugzilla gtkhtml3 component is missing btw.
Comment 1 Jeremy Katz 2003-06-11 11:37:15 EDT
Added in CVS, will be in next build.

Note You need to log in before you can comment on or make changes to this bug.