Bug 97187 - Oops with Cisco Aironet 350-series card reproducible by using VNC
Oops with Cisco Aironet 350-series card reproducible by using VNC
Status: CLOSED DUPLICATE of bug 83363
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 07:40 EDT by Richard Kinder
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Kinder 2003-06-11 07:40:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
When using VNC via the wireless interface (Cisco Aironet card via a PCI->cardbus
adapter, 128-bit WEP enabled), the following oops is encountered. After the
oops, nothing except the mouse works on the system.

Jun 11 20:59:39 localhost kernel: spurious 8259A interrupt: IRQ7.
Jun 11 21:00:34 localhost kernel: airo: BAP error 4000 2
Jun 11 21:00:34 localhost kernel: Warning: kfree_skb passed an skb still on a
list (from c0120baa).
Jun 11 21:00:34 localhost kernel: ------------[ cut here ]------------
Jun 11 21:00:34 localhost kernel: kernel BUG at skbuff.c:315!
Jun 11 21:00:34 localhost kernel: invalid operand: 0000
Jun 11 21:00:34 localhost kernel: radeon agpgart parport_pc lp parport airo_cs
airo autofs ds yenta_socket pcmcia_core 8139too mii ipt_REJECT iptable_filter
ip_tables sg sr_mod ide-scsi scsi_m
Jun 11 21:00:34 localhost kernel: CPU:    0
Jun 11 21:00:34 localhost kernel: EIP:    0060:[<c01ea0d4>]    Not tainted
Jun 11 21:00:34 localhost kernel: EFLAGS: 00010282
Jun 11 21:00:34 localhost kernel:
Jun 11 21:00:34 localhost kernel: EIP is at __kfree_skb [kernel] 0x140 (2.4.20-8)
Jun 11 21:00:34 localhost kernel: eax: 00000045   ebx: d85e83c0   ecx: dee0c000
  edx: dee0df7c
Jun 11 21:00:34 localhost kernel: esi: c23a5f90   edi: c23a4306   ebp: c23a4000
  esp: c23a5f78
Jun 11 21:00:34 localhost kernel: ds: 0068   es: 0068   ss: 0068
Jun 11 21:00:34 localhost kernel: Process keventd (pid: 2, stackpage=c23a5000)
Jun 11 21:00:34 localhost kernel: Stack: c026c200 c0120baa c23a4306 c23a5f90
c0120baa d85e83c0 dfb042e4 dfb042e4
Jun 11 21:00:34 localhost kernel:        00000001 c02550bb c012a623 c0302e50
c23a5fb0 00000000 00000001 00000000
Jun 11 21:00:34 localhost kernel:        c0364d00 00010000 00000000 c012a510
00000000 c035eadc 00000000 c23a4000
Jun 11 21:00:34 localhost kernel: Call Trace:   [<c0120baa>] __run_task_queue
[kernel] 0x52 (0xc23a5f7c))
Jun 11 21:00:34 localhost kernel: [<c0120baa>] __run_task_queue [kernel] 0x52
(0xc23a5f88))
Jun 11 21:00:34 localhost kernel: [<c012a623>] context_thread [kernel] 0x113
(0xc23a5fa0))
Jun 11 21:00:34 localhost kernel: [<c012a510>] context_thread [kernel] 0x0
(0xc23a5fc4))
Jun 11 21:00:34 localhost kernel: [<c012a510>] context_thread [kernel] 0x0
(0xc23a5fe0))
Jun 11 21:00:34 localhost kernel: [<c0107389>] kernel_thread_helper [kernel] 0x5
(0xc23a5ff0))
Jun 11 21:00:34 localhost kernel:
Jun 11 21:00:34 localhost kernel:
Jun 11 21:00:34 localhost kernel: Code: 0f 0b 3b 01 f3 af 26 c0 8b 5c 24 14 e9
c2 fe ff ff 8d 76 00
Jun 11 21:00:34 localhost kernel:  <3>airo: BAP error 4000 2
Jun 11 21:00:34 localhost kernel: airo: BAP error 4000 2

Please let me know what other information you need.

Version-Release number of selected component (if applicable):
kernel-2.4.20-8

How reproducible:
Always

Steps to Reproduce:
1. Start up a VNC server on, eg :1
2. Connect to the VNC server via another wireless card via an AP
3. Eventually, the computer will oops.
    

Actual Results:  The oops as detailed in the description

Expected Results:  No oops.

Additional info:

This all worked fine and dandy on redhat 8.0 (the current system is an upgrade
from 8.0 to 9.0).
Comment 1 Richard Kinder 2003-06-11 20:06:40 EDT
Looks like a duplicate of 83363.
Comment 2 Alan Cox 2003-06-22 14:33:03 EDT

*** This bug has been marked as a duplicate of 83363 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.