Bug 971874 - engine: engine restart during DeleteImage step will cause reporting issues and ArrayIndexOutOfBoundsException: -1
Summary: engine: engine restart during DeleteImage step will cause reporting issues an...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine   
(Show other bugs)
Version: 3.2.0
Hardware: x86_64 Linux
unspecified
high
Target Milestone: ---
: 3.2.1
Assignee: Daniel Erez
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Keywords: ZStream
Depends On: 962497
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 13:30 UTC by Idith Tal-Kohen
Modified: 2016-02-10 20:21 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously,restarting the engine during the DeleteImage step of live storage migration would create an exception error reading: "ArrayIndexOutOfBoundsException: -1". This also caused reporting issues in the log, with several messages stuck on loop until the engine was restarted again. Now, restarting the engine during live storage migration does not disrupt the migration process and does not produce unnecessary errors in the log.
Story Points: ---
Clone Of: 962497
Environment:
Last Closed: 2013-07-16 13:40:36 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1048 normal SHIPPED_LIVE rhevm 3.2.1 bug fix update 2013-07-19 05:45:47 UTC
oVirt gerrit 15133 None None None Never

Comment 3 Aharon Canan 2013-07-01 12:29:02 UTC
verified using sf18.2

verification was done using reproduction steps from first comment.

no messages in endless loop in logs, 
tasks cleared.

Comment 5 errata-xmlrpc 2013-07-16 13:40:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html


Note You need to log in before you can comment on or make changes to this bug.