Bug 971883 - engine: vm image remains locked with 'ArrayIndexOutOfBoundsException: -1' when vdsm restarts on spm after complete of task "syncData"
Summary: engine: vm image remains locked with 'ArrayIndexOutOfBoundsException: -1' whe...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine   
(Show other bugs)
Version: 3.2.0
Hardware: x86_64 Unspecified
unspecified
high
Target Milestone: ---
: 3.2.1
Assignee: Daniel Erez
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Keywords: ZStream
Depends On: 965676
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 13:36 UTC by Idith Tal-Kohen
Modified: 2018-12-03 19:04 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, an exception was left in the engine logs when the engine failed to clean cloneImageStructure tasks with ArrayIndexOutOfBoundsException. Such exceptions are now cleaned from the engine logs. (Note: the images associated with such exceptions are still left on the target domains. Cleanup of target domains in such situations is expected to be implemented in a future version of Red Hat Enterprise Virtualization Manager.)
Story Points: ---
Clone Of: 965676
Environment:
Last Closed: 2013-07-16 13:40:49 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1048 normal SHIPPED_LIVE rhevm 3.2.1 bug fix update 2013-07-19 05:45:47 UTC
oVirt gerrit 15133 None None None Never

Comment 3 Aharon Canan 2013-06-27 12:50:25 UTC
verified using sf18.2


1. in iscsi storage with two hosts, create a vm from template
2. run the vm on hsm
3. start a live storage migration on the vm disk
4. restart vdsm on the spm when syncImageData task has change state to completed successfully in SPM

logs are clean with now above errors

Comment 5 errata-xmlrpc 2013-07-16 13:40:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1048.html


Note You need to log in before you can comment on or make changes to this bug.