Bug 971919 - CLI - 'user_role add_ldap_group' shows error.
CLI - 'user_role add_ldap_group' shows error.
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Hayk Hovsepyan
: Triaged
Depends On: 997081
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 10:55 EDT by Hayk Hovsepyan
Modified: 2015-05-04 21:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-07 10:13:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-06-07 10:55:32 EDT
Description of problem:
Install Satellite6 from latest puddle, configure it with LDAP server with type  'posix'.

Create user_role and try to add LDAP group into it. You will see error displayed: "LdapFluff::Posix::MemberService::UIDNotFoundException"

I have used these config options:
'katello-configure --deployment=katello --user-name=hhovsepy --ldap-server='ldap.rdu.redhat.com' --ldap-encryption=start_tls --ldap-users-basedn='ou=users,dc=redhat,dc=com' --ldap-group-basedn='ou=groups,dc=redhat,dc=com' --auth-method=ldap'

Steps to duplicate.
1. Install latest Satellite6 drop.
2. Configure with LDAP server of 'posix' type.
3. Create 'user_role' in katello.
4. Add some LDAP group 'admins' into that 'user_role'. You will see the error here.

On previous drop, other error was shown here: "undefined method `empty?' for false:FalseClass". But this error was also for 'free_ipa' LDAP as well and now is fixed.

Version-Release number of selected component (if applicable):
Katello-Katello-Installation-Satellite6WithLdap-1.0.0-5.noarch
foreman-postgresql-1.1.10004-1.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
openldap-2.4.23-26.el6.x86_64
katello-certs-tools-1.4.2-2.el6sat.noarch
foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
katello-common-1.4.2-10.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
Katello-Katello-Configuration-KatelloClient-1.1-45.noarch
signo-0.0.16-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
foreman-1.1.10004-1.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-configure-1.4.3-14.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
signo-katello-0.0.16-1.el6sat.noarch
katello-glue-candlepin-1.4.2-10.el6sat.noarch
katello-glue-pulp-1.4.2-10.el6sat.noarch
katello-1.4.2-10.el6sat.noarch
katello-configure-foreman-1.4.3-14.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-10.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-cli-1.4.2-7.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
katello-all-1.4.2-10.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch

How reproducible:
always
Comment 2 Petr Chalupa 2013-10-18 10:11:26 EDT
It looks like there is no admin-group group in ldap.rdu.redhat.com LDAP. It worked for me with admin-emea. Moving to ON_QA for verification.
Comment 3 Hayk Hovsepyan 2013-10-24 09:51:10 EDT
Tested on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
katello-cli-1.4.3-27.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
katello-common-1.4.6-47.el6sat.noarch
katello-glue-elasticsearch-1.4.6-47.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-demeter.usersys.redhat.com-1.0-1.noarch
Katello-Katello-Installation-Satellite6WithLdap-1.0.0-6.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.22.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
foreman-1.3.0-20.el6sat.noarch
katello-cli-common-1.4.3-27.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-server-2.3.0-0.22.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-pulp-1.4.6-47.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-47.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
katello-all-1.4.6-47.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-0.0.23-2.el6sat.noarch
foreman-postgresql-1.3.0-20.el6sat.noarch
pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.6-47.el6sat.noarch
candlepin-0.8.25-1.el6sam.noarch
katello-foreman-all-1.4.6-47.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch


Now it added valid LDAP group into role, but in CLI output it prints "LdapFluff::Posix::MemberService::UIDNotFoundException".
But user role info shows added ldap group.

Please fix the output message.
Comment 6 Petr Chalupa 2014-10-07 10:13:15 EDT
the underling code changed too much

Note You need to log in before you can comment on or make changes to this bug.