Bug 971923 - blender crashes switching viewport Abrt does nothing
blender crashes switching viewport Abrt does nothing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 11:19 EDT by Joshua
Modified: 2013-08-27 04:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 04:34:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua 2013-06-07 11:19:53 EDT
Description of problem:
Any attempt to use the number pad to change viewport angle causes blender to crash without warning Abrt does not pick up the crash but a 'blender.crash.txt' file is written to tmp.

Version-Release number of selected component (if applicable):
blender-2.67a-3.fc19.x86_64

How reproducible:
100%


Steps to Reproduce:
1.open a blend file or start a new scene use the number pad to any view.
2.
3.

Actual results:
Application closes instantly

Expected results:


Additional info:
I am using KDE but tried Mate - same thing.
radeon driver ATI RV730/M96
Comment 1 Joshua 2013-06-07 12:23:26 EDT
This issue is not limited to fedora's blender build I have tried versions 2.66a and 2.67a from blender.org with the same results
Comment 2 Joshua 2013-06-07 14:36:55 EDT
running blender in fc19 on virtualbox does not have the problem -- must be an X related problem.
Comment 3 Jochen Schmitt 2013-06-08 12:45:44 EDT
I have pushed blender-2.67b-1.fc19 to updates-testing. It may be nice, if
anyone can try out this package.
Comment 4 Joshua 2013-06-08 15:23:45 EDT
I have tried it with the same result.
I believe the problem is in mesa or the radeon driver.

xsession-errors is full of complaints but it doesn't seem to pick up the crash.
Comment 5 Joshua 2013-06-10 23:22:19 EDT
I just did a major update that included xorg and mesa packages now it seems to be fine.
Comment 6 Joshua 2013-06-11 10:00:27 EDT
No it is not fine. Same problem. I have no idea how to locate the cause. From the console there is no more information than this:

"read blend: /home/josh/Documents/14ethel-deck-rail_City_MV.blend
Warning: edge 88 - 89 appears twice, correcting
Writing: /tmp/14ethel-deck-rail_City_MV_01.crash.txt

[1]+  Segmentation fault      ./blender"
Comment 7 François Cami 2013-08-26 18:06:59 EDT
@Joshua: could you please try launching blender this way:

LIBGL_ALWAYS_SOFTWARE=1 blender

and reproduce the problem?
If it works fine, we have a mesa problem.

If it still crashes, please report this bug to the Blender project.
Their bug tracker is at https://projects.blender.org/tracker/?group_id=9&atid=498
Please include whatever's needed to reproduce the bug.
Comment 8 Joshua 2013-08-26 19:30:30 EDT
I'm not sure where the problem was but as of June 17th updates the problem went away. I suspect radeon driver - I can check the yum logs.
Now the only problem is material view in cycles - there is no crash but only selected objects are visible and without mapped materials.

Starting blender "LIBGL_ALWAYS_SOFTWARE=1 blender &" and now material view works with cycles. I guess I could add it to the launcher.
Comment 9 François Cami 2013-08-27 04:34:02 EDT
@Joshua: yes, I suspect a mesa-libGL update fixed your problem. Switching component to mesa.

Could you please open a new bug, against mesa, explaining the difference in behaviour between:
$ blender
$ LIBGL_ALWAYS_SOFTWARE=1 blender
hopefully with screenshots and how to reproduce things.

Closing.

Note You need to log in before you can comment on or make changes to this bug.