Bug 971937 - Trends: Creation of a new Trend Counter displays trend type, not trend name.
Summary: Trends: Creation of a new Trend Counter displays trend type, not trend name.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning   
(Show other bugs)
Version: Nightly
Hardware: Unspecified Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Sachin Ghai
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 15:51 UTC by Corey Welton
Modified: 2014-07-02 14:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 14:08:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Welton 2013-06-07 15:51:33 UTC
Description of problem:

When a user creates a new Trend Counter, s/he is asked to enter a name.  As far as I can tell, however, this name is never used in the UI.  Rather, the trend type itself is displayed as the trend name

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select Trends from the menu; Add Trend Counter
2. Choose a trend type ("Model") and provide a name ("Model_Trend")
3. Submit; view ensuing Trends view

Actual results:
Trend appears with trend type ("Model") as the 'Name' in the view


Expected results:
Trend appears with trend type ("Model_Trend") as the 'Name' in the view

Additional info:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10004-1.noarch
* foreman-compute-1.1.10004-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10004-1.noarch
* foreman-postgresql-1.1.10004-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-10.el6sat.noarch
* katello-all-1.4.2-10.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-10.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-10.el6sat.noarch
* katello-glue-candlepin-1.4.2-10.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
* katello-glue-pulp-1.4.2-10.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch

Comment 3 jmagen@redhat.com 2013-09-17 07:58:49 UTC
I think we should disable trend name if not a FactTrend.

https://github.com/theforeman/foreman/pull/888

Comment 4 Sam Kottler 2013-09-23 15:57:56 UTC
https://github.com/theforeman/foreman/pull/888 has been merged upstream.

Comment 7 Mike McCune 2013-10-17 21:00:48 UTC
Moving this to be tested during MDP3, not critical for MDP2 success story

Comment 10 Garik Khachikyan 2014-03-24 12:20:27 UTC
qa_ack-ed

Comment 11 Jan Hutař 2014-03-25 09:30:04 UTC
Seems that on Satellite-6.0.3-RHEL-6-20140321.2 compose this is still broken or maybe I'm doing something wrong (?):

1. Go to Monitor -> Trends -> Add Trend Counter
2. Select Trend Type: Model
   (note that you can not edit "Name" field)
3. Trend gets created with name "Model"

Comment 12 jmagen@redhat.com 2014-05-11 07:59:32 UTC
Jan, I think it is working correcting. For any Trend Type that is not Facts, a user now cannot enter/edit the name. 

Before the fix on https://github.com/theforeman/foreman/commit/460215e, the trend name could be added if Trend Type was not "Facts", but the name entered did not show up. This was bud.  However, now that a user can't enter the name.

We should correct the bug title from 

"Trends: Creation of a new Trend Counter displays trend type, not trend name"

to 

"Trends: Creation of a new Trend Counter should show trend type for Foreman Trends and trend name for Fact Trends"

Let me know if you have any questions.

Comment 13 jmagen@redhat.com 2014-05-19 12:09:15 UTC
ping

Comment 14 Dominic Cleal 2014-05-20 15:46:10 UTC
As Joseph said, the behaviour described in comment #11 is expected.  The fix was to prevent editing of the name field for the built in trend types.  It wasn't intended to be editable for these, only for fact-based trends.

Comment 15 Sachin Ghai 2014-06-10 10:25:21 UTC
Verified with sat6 beta snap8. 

So as per the comment 12. We can enter/edit name for all trend types except "Facts". Looks like name field is disabled. If we choose "Facts" trend type then we can define a name and the same name appears when we view the trends. So Moving this to verified.

Comment 16 Sachin Ghai 2014-06-10 10:27:03 UTC
Correction: Please re-read comment15

We can **not** enter/edit name for all trend types except "Facts"

Comment 17 Jan Hutař 2014-06-12 20:23:44 UTC
(In reply to jmagen@redhat.com from comment #12)
> Jan, I think it is working correcting. For any Trend Type that is not Facts,
> a user now cannot enter/edit the name. 
> [...]

Sorry for missing the conversation for so long. Thanks Sachin for QE work.

Comment 18 Bryan Kearney 2014-07-02 14:08:01 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.