Bug 97196 - RFE: parse /etc/modprobe.d/*
RFE: parse /etc/modprobe.d/*
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2003-06-11 09:22 EDT by Oeystein Olsen
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:07:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oeystein Olsen 2003-06-11 09:22:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have Compaq Multiport W200 radiocard. The driver was downloaded from 
http://ranty.ddts.net/~ranty/orinoco/  The driver installed without any
problems. Now if I run ifconfig, I have the devices lo, eth0 and wlan0. 
iwconfig recognizes wlan0 as a wireless lan. Neat does not recognize this
wireless lan. (Bug ?)

I created manually an ifcfg-wlan0, and I could start up the wireless lan with
"ifup  wlan0". If I create network profiles involving wlan0 manually, network
profiles work as it should. But if I start up neat and choose to  edit the wlan0
device, wlan0 is replaced by ethX and ifup doesn't work anynore. 

[If I try to configure the wireless lan with neat, then choosing other network
card -> card that loads the driver (lucent/orinico), I get the message that the
device isn't present when I try to activate. If I rename ifcfg-eth1 to
ifcfg-wlan0 and replacing eth1 with wlan0, then "ifup wlan0" works. "ifup et1"
never worked]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure wlan0 device manually, since neat doesn't recognize wlan0
2. Edit device with neat. 
    

Actual Results:  The files ifcfg-wlan0 are renamed to ifcfg-ethX. The files are
edited and the DEVICE=wlan0 is replaced with DEVICE=eth1

Expected Results:  Neat should recognize wlanX devices and treat the similar to
ppp0 , eth0  devices

Additional info:
Comment 1 Gary Fidler 2003-06-16 12:43:19 EDT
I have the same problem with some different environment items.  I have a
ThinkPad with a built-in Prism-based wireless card.  I use the "hostap" driver,
which also provides a wlan0 device.  It is neat's naming convention of "ethx"
that causes the problem.  It is not prepared to create wlan0 devices.  I can
make the system work without neat.  If I edit the config with neat, it changes
the device name and renames the ifcfg file to ethx.  Then I can't run "ifup
wlan0" anymore.
Comment 2 x1 2004-06-09 05:54:01 EDT
It's still not fixed in FC-2 - I cannot config wlan* devices with
system-config-network.
Comment 3 Kim Lux 2004-11-03 12:00:52 EST
I have quite a bit of experience with configuring wlanx devices with 
system-config-network.  Please post a copy of the ifcfg-wlan0 file 
you started with.  
 
 
We use ndiswrapper with the Broadcom wireless cards and 
system-config-network will change the config in ifcfg-wlan0 in that 
setup.  
 
Visit www.zd7000forums.com and look under Linux.  There is a wireless 
HOWTO there that works well.  
Comment 4 Tobias Oed 2006-04-25 19:12:48 EDT
This is with FC5.
I'm also using ndiswrapper and it works. But only 
if I put "alias wlan0 ndiswrapper" in /etc/modprobe.conf
instead of /etc/modprobe.d/ndiswrapper (where the
ndiswrapper prog puts it)
So aparently the module scanning of neat is broken.
Tobias

Note You need to log in before you can comment on or make changes to this bug.