Bug 972 - Both backspace and delete act as delete in Netscape.
Both backspace and delete act as delete in Netscape.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-27 00:34 EST by John
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-12 17:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John 1999-01-27 00:34:42 EST
In Redhat Linux 5.2 in a Pentium, both backspace and delete
act as a delete key.  That is, both keys delete the
character to the right of the cursor, rather than the
backspace key deleting the character to the left of the
cursor.

I haven't modified the keymaps under X at all... this
behaviour  seemed to occur straight out of the box.

(I gave the bug high priority because it's even annoying me
as I type this bug report into Bugzilla! :)

Thanks for looking into this bug!

Sincerely,
John Karcz
Comment 1 David Lawrence 1999-03-12 17:48:59 EST
I was unable to replicate this problem on a fresh install of 5.2 using
Netscape-Communicator-4.07-1.
Comment 2 ysyi 1999-05-25 23:54:59 EDT
It's not just a Netscape "problem"; in fact, it's not an
application-based problem at all. It X11's key mapping.
Put this in a file (e.g., ~/.xmodmap):

keycode 107 = Delete
keycode 22 = BackSpace

and run `xmodmap ~/.xmodmap`, or `xmodmap -e 'keycode 107 = Delete'`,
and so on. It should fix the problem (depending on which keyboard you
defined in XF86Config, and what keyboard you're using, etc). If it
works, you may wish to run it from ~/.xinitrc or similar.

While you're at it, you might want to check out "xkeycaps" (do a
netsearch for it, or http://www.jwz.org/), if you wish to have an
easier, more intuitive way to remap keys.

I hope this helps!

Note You need to log in before you can comment on or make changes to this bug.