Bug 97211 - Stated usage of active partition flag is misleading
Stated usage of active partition flag is misleading
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
Sandra Moore
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 12:26 EDT by Bob Hanner
Modified: 2014-08-04 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 15:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Hanner 2003-06-11 12:26:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.0.1) Gecko/20020919 IBM
Web Browser for OS/2

Description of problem:
On page 108 a sentence reads:

The "active" flag is used by some operating systems' boot loaders.

This is possibly correct, but misleading.  The "active" flag is actually used by
the computer's BIOS to select which hard disk primary partition to boot.  The
contents of that partition may be an operating system boot loader or an
operating system selection program such as GRUB, LILO or OS/2 Boot Manager. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Read page 108
2.
3.
    

Additional info:
Comment 1 Bob Hanner 2003-06-11 18:04:38 EDT
As I got further into the installation I realized I didn't give the correct
interpretation either.  In section 3.20.1 the book correctly states that the
MBR, not the active partition, is the code loaded by the BIOS.  I think the
description on page 108 should connect the two ideas.  All MBRs that I know of,
except those supplied with Linux, use the "active" flag to determine which
partition to boot.  Operating system selectors such as OS/2 Boot Manager take up
a partition and reside in the one marked active.  Some selectors such as GRUB
and LILO apparently are different in that they can reside entirely or partially
in the MBR.  I say partially because the MBR isn't very big and I wonder if that
much function will fit.        
Comment 2 Sandra Moore 2003-06-17 15:52:44 EDT
Thanks again for the feedback. I'll work with the original author of this
content to clarify this as well as relate it back to the partitioning
information earlier in the Installation Guide.

Cheers,
Sandra

Note You need to log in before you can comment on or make changes to this bug.