Bug 972150 - SELinux is preventing /usr/sbin/drbdadm from 'execute' accesses on the file /usr/sbin/drbdmeta.
SELinux is preventing /usr/sbin/drbdadm from 'execute' accesses on the file /...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3df9ae4757c3f8d789235792ed7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 15:34 EDT by Daniel Bossert
Modified: 2013-06-07 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 16:11:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Bossert 2013-06-07 15:34:30 EDT
Description of problem:
SELinux is preventing /usr/sbin/drbdadm from 'execute' accesses on the file /usr/sbin/drbdmeta.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es drbdadm standardmässig erlaubt sein sollte, execute Zugriff auf drbdmeta file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep drbdadm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:drbd_t:s0
Target Context                system_u:object_r:bin_t:s0
Target Objects                /usr/sbin/drbdmeta [ file ]
Source                        drbdadm
Source Path                   /usr/sbin/drbdadm
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           drbd-utils-8.4.2-2.fc19.x86_64
Target RPM Packages           drbd-utils-8.4.2-2.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-48.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-301.fc19.x86_64 #1 SMP Tue
                              Jun 4 00:30:04 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-06-07 20:46:53 CEST
Last Seen                     2013-06-07 21:31:57 CEST
Local ID                      fd0f719f-c55b-4ff0-b4ce-fbcb4e813513

Raw Audit Messages
type=AVC msg=audit(1370633517.253:59): avc:  denied  { execute } for  pid=970 comm="drbdadm" name="drbdmeta" dev="dm-0" ino=1333313 scontext=system_u:system_r:drbd_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file


type=SYSCALL msg=audit(1370633517.253:59): arch=x86_64 syscall=access success=no exit=EACCES a0=16f2030 a1=1 a2=8 a3=e items=0 ppid=949 pid=970 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=drbdadm exe=/usr/sbin/drbdadm subj=system_u:system_r:drbd_t:s0 key=(null)

Hash: drbdadm,drbd_t,bin_t,file,execute

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-301.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-06-07 16:11:01 EDT
Looks like /usr/sbin/drbdmeta  is mislabeled.

restorecon /usr/sbin/drb* -v 

Should fix the problem

Note You need to log in before you can comment on or make changes to this bug.