Bug 972156 - iso sync let me sync a cdn repo without specifying the certs
iso sync let me sync a cdn repo without specifying the certs
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity medium
: ---
: 2.3.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 15:36 EDT by Preethi Thomas
Modified: 2013-12-09 09:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:30:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-06-07 15:36:49 EDT
Description of problem:

I was able to sync a cdn iso repo without specifying the certs. Not sure if having created the repo previously had anything to do with it. I will explain the steps I did
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create CDN iso repo with certs
2.  Sync the repo
3. Delete the repo
4. Make sure that the iso files are deleted from the filesystem
5. Create a second repo with CDN feed  but do not use the certs
6. Sync the repo

Actual results:
cdn repos are able sync without the certs


Expected results:


Additional info:
Comment 1 Randy Barlow 2013-06-12 17:05:05 EDT
This is due to a bug in Nectar, which I've marked as a blocker for this bug.
Comment 2 Michael Hrivnak 2013-09-26 15:30:54 EDT
https://github.com/pulp/pulp_rpm/pull/341

The above PR should fix this as well.
Comment 3 Jeff Ortel 2013-09-26 16:54:13 EDT
build: 2.3.0-0.16.alpha
Comment 4 Preethi Thomas 2013-10-02 08:25:59 EDT
verified
[root@ibm-ls22-02 ~]# rpm -qa |grep pulp-server
pulp-server-2.3.0-0.16.alpha.el6.noarch
[root@ibm-ls22-02 ~]# 


[root@ibm-ls22-02 ~]# pulp-admin iso repo create --repo-id iso-rhel6 --feed https://cdn.redhat.com/content/dist/rhel/rhui/server/6/6.4/i386/iso/ 
Successfully created repository [iso-rhel6]


[root@ibm-ls22-02 ~]# 
[root@ibm-ls22-02 ~]# pulp-admin iso repo sync run --repo-id iso-rhel6
+----------------------------------------------------------------------+
                  Synchronizing Repository [iso-rhel6]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest...
Downloading the Pulp Manifest failed:

	{}
Comment 5 Preethi Thomas 2013-12-09 09:30:19 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.