Bug 972192 - unsuccessful ssh connection to spacewalk to fetch report results in temporary data loss
unsuccessful ssh connection to spacewalk to fetch report results in temporary...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-07 15:52 EDT by Chris Duryee
Modified: 2013-10-01 07:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:11:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2013-06-07 15:52:49 EDT
Description of problem:

If spacewalk-splice-tool is not able to connect via ssh to the spacewalk machine, or if spacewalk-reports returns an error, then the script assumes that there are no more orgs or systems and will remove them from katello.

Version-Release number of selected component (if applicable): 0.19


How reproducible: every time


Steps to Reproduce:
1. break ssh access somehow (shut down sshd, or shut down postgresql on spacewalk server)
2. run spacewalk-splice-checkin --spacewalk-sync

Actual results: orgs and systems are removed from katello. They will come back if the underlying ssh or spacewalk-report error is fixed.

Expected results: an exception is thrown and logged, and the script does not run further.
Comment 1 James Slagle 2013-06-10 15:28:54 EDT
commit 2009d717141b965925e502364ada5fbbb2679c32 to spacewalk-splice-tool

non-zero exit code from ssh is now logged and the program is exited.
Comment 3 Vitaly Kuznetsov 2013-06-18 07:40:58 EDT
Verified in spacewalk-splice-tool-0.20-1.el6sam:

[root@ec2-54-216-161-93 ~]# spacewalk-splice-checkin 
[root@ec2-54-216-161-93 ~]# echo $?
126

The data in Katello is in place.
Comment 6 errata-xmlrpc 2013-10-01 07:11:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.