Bug 972251 - python-lamson has incorrect License tag
python-lamson has incorrect License tag
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-lamson (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Praveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 969594
  Show dependency treegraph
 
Reported: 2013-06-07 20:52 EDT by Matt Molyneaux
Modified: 2013-06-25 13:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 17:46:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Molyneaux 2013-06-07 20:52:49 EDT
rpm -qi python-lamson states the license as GPLv3, however the LICENSE file appears to be a modified version of the BSD license.

Also, this license appears to have a rather worrying clause:
5. The copyright holder reserves the right to revoke this license on anyone who
uses this copyrighted work at any time for any reason.
Comment 1 Rahul Sundaram 2013-06-07 21:22:17 EDT
Strange.  It was certainly under GPL before.  

http://zedshaw.com/essays/why_i_gpl.html

The author even wrote a long post explaining his rationale.  The current license appears non-free however.  

https://github.com/zedshaw/lamson/blob/master/LICENSE

Copying Spot.
Comment 2 Praveen Kumar 2013-06-08 01:22:14 EDT
What would be the our step in this situation, should we ask author to make required changes to License file or we have to drop that package from fedora repo?
Comment 3 Matt Molyneaux 2013-06-08 04:51:27 EDT
When I first realised Lamson had this license I did try contacting the author in the #lamson IRC channel on Freenode, but received no response.

I have since made a fork of the last GPLv3 version of Lamson, however it now relies on a library not yet packaged for Fedora. The fork is here:
https://pypi.python.org/pypi/salmon-mail/0

Obviously, it is missing all the bug fixes from the last year :(
Comment 4 Praveen Kumar 2013-06-08 10:26:53 EDT
I sent a mail about this issue to author, I am hoping he will response back. I don't think it's a good idea to use older source release which don't have latest bug fixes.
Comment 5 Praveen Kumar 2013-06-09 03:29:11 EDT
Below response which I got from author.

copying from Mail:
You should probably just pull the project from fedora and not include
it, as my license is retroactive and removes the GPLv3 license I had before.
Sorry but this is my right as a copyright holder and since nobody has given me
an exchange for the license it's not a contract and I can cancel it at any
time.

Again, sorry for the harshness of the stance but I'm pretty adamant about being
able to revoke the license on this piece of software and that the license is
not a contract and therefore I don't have to let people use Lamson
indefinitely.  Refer to this article for some other insights:

http://lwn.net/Articles/61292/
Comment 6 Rahul Sundaram 2013-06-09 13:51:51 EDT
The developer seems confused.  He cannot change the license of the software he released before retroactively.  Once a software is released under GPL, that particular version is under GPL forever.  However subsequent versions can be relicensed under any license the author chooses if he/she is the sole copyright holder.  It appears that the current license is non-free and I would like Red Hat Legal to confirm this.  Once we have confirmation that the current license is non-free, our options are 

a) convince the developer to go back to the previous license.  I am not sure why the developer has changed the license.  That is unfortunate. If we cannot convince him, we can package a snapshot just before he changed the license but it will be unmaintained. 

b) switch to the salmon-mail fork although we are losing some bug fixes and it is not clear whether that fork is going to be maintained going forward.  If it is not, it is not any different from a)

c) drop the software entirely.  askbot has a dependency on it but I think it only is needed when running it using celery which we don't and don't plan to.
Comment 7 Tom "spot" Callaway 2013-06-10 12:18:33 EDT
Clause 4 is odd, but Clause 5 makes it clearly non-free.

I agree with what Rahul has said in Comment 6, and his options are the ones I would put forth, with a slight preference to option c (just because upstream seems to be a bit on the crazy side).
Comment 8 Rahul Sundaram 2013-06-10 17:46:00 EDT
I have retired python-lamson and dropped the dependency on askbot for now.  I will be open to packaging up salmon-mail (and deps) instead and adding an obsolete if that fork is going to be actively maintained.  Thanks for the report and Spot for confirming that the current license is non-free.
Comment 9 Matt Molyneaux 2013-06-25 10:02:38 EDT
I'm the only contributor to Salmon and as far as I can tell, the only user too. I certainly won't be pushing for inclusion in Fedora until I've know of a few people using it and submitting bug reports.
Comment 10 Rahul Sundaram 2013-06-25 13:09:53 EDT
Other distributions including Debian, openSUSE etc would certainly be interested in a free fork.  Large python software that has dependencies on lamson would be as well.  I would use those as a starting point to get some more users.

Note You need to log in before you can comment on or make changes to this bug.