Bug 972256 - The release notes on the website have grammar errors, missing words. Not all my corrections were implemented.
The release notes on the website have grammar errors, missing words. Not all ...
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
other Other
unspecified Severity medium
: ---
: ---
Assigned To: Pete Travis
Fedora Docs QA
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 22:26 EDT by Leslie Satenstein
Modified: 2013-08-01 02:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 02:26:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected Fedora 19 release notes. (64.94 KB, application/vnd.oasis.opendocument.text)
2013-06-07 22:26 EDT, Leslie Satenstein
no flags Details
French Release notes as copied from the Website. (61 bytes, text/plain)
2013-06-28 20:06 EDT, Leslie Satenstein
lsatenstein: review+
Details
French Release notes (275.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-28 20:07 EDT, Leslie Satenstein
no flags Details
French Release Notes Fed 19 (MS word or LibreOffice Format) (275.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-28 20:08 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2013-06-07 22:26:35 EDT
Created attachment 758390 [details]
Corrected Fedora 19 release notes.

Description of problem:

I worked on the draft of the release notes, pointed out via markups, errors in grammer, missing words and miss spellings. It was decided to not correct some of the errors and publish. I have prepared a document which highlights the errors, and most of all, corrects an omission in an Appendix A3.

My original release notes submission was done at end-April.

Hereto this bug is an update to the release notes. 
I would use the collaboration features of libreoffice, but not everyone knows how to use it. Therefore I have resorted to coloring text yellow to show removals, red to show insertions and to also insert words that were omitted. I also asked some questions as to what the author was trying to say. 

We all, myself included are guilty of omitting words when we write our first draft. Because we think while we write, a good proof read of the document is needed.

So I am reporting 25+ corrections to the release notes shown on the website.

The document with the corrections is attached.  
 
I am also very disappointed that the proofreading effort was not recognized. In that regard, I included an additional Appendix A3. 

Version-Release number of selected component (if applicable):

Fedora 19 Release notes.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Pete Travis 2013-06-07 23:50:37 EDT
First, I want to say that I do appreciate your review and your persistence. There were some embarrassing grammatical faults that might have been missed without you.

I do want to be clear, however: I'm not going to replace every instance of 'on' in the text. Translators and users understand the usage of the word 'on' in contexts other than vertical proximity. Your drawing attention to it does make it seem used excessively, and I'll keep it in mind with future work.  

Many of your suggestions appeared to request rephrasing based on personal preference, often to the detriment of the technical accuracy of the copy.  However, the review was useful in identifying unclear passages, even if it was not applied verbatim.

Here's what I changed:
The sentences about syslinux were confusing, and should read better now.
Corrected the spelling error of "Performace" Co-Pilot
Added the 'to' in the crtools section.
Added a 'from' to the node.js docs package sentence

Frankly, I'm a little surprised that you're requesting formal acknowledgement. Bug reporters, while vital to the open source community, are not typically listed as upstream contributors.
Comment 2 Leslie Satenstein 2013-06-08 10:03:23 EDT
Why the changes. 

In French, Spanish, or non-American English, the word "on does not make sense and cannot be used.  The French cannot say "Je vous parle sur Gnome". (if you do not know the French language, sur means on something physical). Neither is it possible in Spanish or Hebrew to say (in their language) I will talk to you on an individual item. Yes, I concede that we can talk on a topic or grouping. 

So, when we have a Bilingual French, Spanish, or other language individual reading the English text, they have to rethink what is the message.

The second point that was corrected is when you have multiple nouns (subjects) in the same sentence, followed by and, with a qualifier. The gross example was with maria.db and mysql.  Was the large following for maria.db or was it for mysql?

By the same token, A sentence with two subjects is followed by the next sentence beginning  "This  xxxx"   What does the xxxx part refer to? Does it refer to the first item in the previous sentence or the other item.  

I am for writing clearly, and to allow a non-English person to understand the release note, because he is faced with the challenge of a) translating and then b) trying to understand the English readily.

You may not have worked in a technical publishing company. I did two years of writing and having the same corrections slapped back at me.  

I absolutely made sure that the author's description that was in his mind, was correct. Where I was not sure, I marked up the changes with a question.

Now, the next thing to consider is recognition. The proof reading effort is very laborous, and takes hours.  What you saw was not the product of an automated software, but of reading in detail each section, of saying to myself, would a non-English person understand the sentence, or is it correct.

There was more than 10-12 hours spent to proofread 5 chapters. It is no small task. It requires a person with an Software, network and hardware engineering background. That effort deserves recognition 

Why did I raise this bugzilla request? ans: Because the release note itself indicated to do it.

There are 5 CC'd individuals. Let them decide together.  I will go with the flow. I am sure some of the changes will not make it. But that is what a proof reader expects.
Comment 3 Leslie Satenstein 2013-06-08 10:04:15 EDT
One last comment, The F19 is not officially released, and until it is, the release notes are not cast in stone.
Comment 4 Eric Christensen 2013-06-10 08:54:02 EDT
Translations are never word-for-word.  The basic sentence structure of the Spanish language is completely different than that of the English language.  It is up to the translator to make the transition between the languages.  Changes should not be made at the detriment of the facts and not to the readability of the source language.
Comment 5 Leslie Satenstein 2013-06-10 18:53:29 EDT
Eric, I agree with you. English has so many dialects and differences in understanding sentences. From Jamaica, USA, Canada, England, India and elsewhere, the phrases for universality are what I am after.  
Regarding the use of on.
Le livre est sur le bureau. Je veux parler sur annaconda is the translation from
"The book is on the desk. I want to talk to you on annaconda.". In French we cannot use sur annaconda.  In Spanish can I write "Quiero hablar con usted en anaconda." or should I write " Quiero hablar con usted acerca de anaconda.". I think that the use of "on" for "about" is American practice only.

I also had another situation in the sentence comparing maria.db and mysql and the reference "has a great following." or something like that. I took it to mean that mysql has a great following, but I believe the author meant it to be maria.db has a great following. (refer to the text I uploaded).

I firmly believe that there are some important rules for documentation.
a) The sentences should be at a high school level (standard public writing practices)
b) The sentences should have no spelling mistakes.
c) The links are verified at time of writing, and again by the proof reader.
d) That someone who uses Google translate or other software gets a good translated sentence.

Regarding languages, my wife is Spanish, I am English, but I work 95% in French. At home we speak all three languages. I cringe from the little English errors. 
 
All I am after is to allot time for a good proof read of a public document before it goes public. Proof reading is a very difficult task. You must know the subject well, and then know your language well.  

There are too many discussions about this one Release Note. You may do with it what you want. I did what I had to do.  I most certainly do not have exclusivity on group decisions.

  

  https://bugzilla.redhat.com/buglist.cgi?regetlastlist=1434366
Comment 6 Bryan Sutherland 2013-06-10 20:31:44 EDT
I think the gist of this conversation relies on the individual translator. I would expect that anyone that is doing the translation is able to understand the usage of the phrase and not use a literal "on" as used in your example.

You have to remember that the translators typically are translating into their native language. So in your example, you wouldn't do a literal translation as you know that wouldn't make sense so the documentation is "correct" in both dialects.
Comment 7 Leslie Satenstein 2013-06-13 20:48:04 EDT
Please close. It has delivered its message. Please do not kill the messenger. (grin)
Comment 8 Pete Travis 2013-06-13 21:07:52 EDT
We have a QA process and an established bugzilla workflow. Please don't change the status of bugs assigned to others.
Comment 9 Leslie Satenstein 2013-06-28 20:06:10 EDT
Created attachment 766773 [details]
French Release notes as copied from the Website.
Comment 10 Leslie Satenstein 2013-06-28 20:07:20 EDT
Created attachment 766774 [details]
French Release notes
Comment 11 Leslie Satenstein 2013-06-28 20:08:38 EDT
Created attachment 766775 [details]
French Release Notes Fed 19 (MS word or LibreOffice Format)
Comment 12 Leslie Satenstein 2013-07-01 15:02:53 EDT
Please forward to the L10n group (French Translation markeup and authoring of missing translations)

Note You need to log in before you can comment on or make changes to this bug.