Bug 97226 - clock doesn't get set to local time when booting
clock doesn't get set to local time when booting
Status: CLOSED DUPLICATE of bug 91228
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2003-06-11 13:14 EDT by Tobias Oed
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tobias Oed 2003-06-11 13:14:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
I have /usr on it's own partition and my hardware clock is set to the local time. 
When booting, rc.sysinit syncs the system clock to the hardware clock before /usr is mounted. hwclock uses the file /etc/localtime to determine what timezone I'm in. This is a symbolic link to somewhere under /usr. Because /usr is not mounted yet the link is broken and UTC is assumed. As a result my clock is off. Copying the file from /usr/... to /etc/localtime fixes the problem.

Version-Release number of selected component (if applicable):
red hat 9

How reproducible:

Steps to Reproduce:
1. See description

Actual Results:  The clock is off

Additional info:
Comment 1 Bill Nottingham 2003-06-11 14:49:07 EDT
It shouldn't be a symbolic link, it should be a file. How did it get created in
your case?
Comment 2 Tobias Oed 2003-06-11 20:22:02 EDT
After some more investigation I found out that it's  
redhat-config-time that creates the symlink.  
So that's the culprit. Should refile another bug report  
against that?  
Comment 3 Bill Nottingham 2003-06-11 20:48:41 EDT
Nah, I can just assign it to redhat-config-date.
Comment 4 Brent Fox 2003-06-17 18:35:18 EDT
Looks like a dupe of bug #91228.  A fix is available in Rawhide.

*** This bug has been marked as a duplicate of 91228 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:56:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.