Bug 972291 - fdisk shows that the optimal I/O size is same as the minimum I/O size but actually it's 0
fdisk shows that the optimal I/O size is same as the minimum I/O size but act...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 03:52 EDT by Xiaowei Li
Modified: 2015-01-26 19:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 09:16:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2013-06-08 03:52:38 EDT
Description of problem:
fdisk display that the optimal I/O size is 512 bytes same as the minimum I/O size, but actually it's 0.

Is it by design?

Version-Release number of selected component (if applicable):
util-linux-ng-2.17.2-12.9.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.

# cat /sys/block/sda/queue/optimal_io_size 
0

# fdisk -l /dev/sda

Disk /dev/sda: 299.0 GB, 298999349248 bytes
255 heads, 63 sectors/track, 36351 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000193b4

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          64      512000   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              64       36352   291478528   8e  Linux LVM


2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Karel Zak 2013-06-10 09:16:11 EDT
Sure, optimal I/O size is optional value -- if undefined them fdisk defaults to minimal I/O size. This is expected behaviour.

fdisk is not tool to provide information about your HW or system setting -- if you want such information then use lsblk(8).

Note You need to log in before you can comment on or make changes to this bug.