Bug 972320 - SELinux is preventing /home/mikhail/.local/share/Steam/ubuntu12_32/steam from using the 'execheap' accesses on a process.
Summary: SELinux is preventing /home/mikhail/.local/share/Steam/ubuntu12_32/steam from...
Status: CLOSED DUPLICATE of bug 894788
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 19
Hardware: i686 Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3767d6e9f4cd51f050dd062f15c...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-08 11:51 UTC by Mikhail
Modified: 2013-06-12 07:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 07:43:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikhail 2013-06-08 11:51:54 UTC
Description of problem:
SELinux is preventing /home/mikhail/.local/share/Steam/ubuntu12_32/steam from using the 'execheap' accesses on a process.

*****  Plugin allow_execheap (53.1 confidence) suggests  *********************

If you do not think /home/mikhail/.local/share/Steam/ubuntu12_32/steam should need to map heap memory that is both writable and executable.
Then you need to report a bug. This is a potentially dangerous access.
Do
contact your security administrator and report this issue.

*****  Plugin catchall_boolean (42.6 confidence) suggests  *******************

If you want to allow unconfined executables to make their heap memory executable.  Doing this is a really bad idea. Probably indicates a badly coded executable, but could indicate an attack. This executable should be reported in bugzilla
Then you must tell SELinux about this by enabling the 'selinuxuser_execheap' boolean.
You can read 'unconfined_selinux' man page for more details.
Do
setsebool -P selinuxuser_execheap 1

*****  Plugin catchall (5.76 confidence) suggests  ***************************

If you believe that steam should be allowed execheap access on processes labeled unconfined_t by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep steam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                 [ process ]
Source                        steam
Source Path                   /home/mikhail/.local/share/Steam/ubuntu12_32/steam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-48.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-301.fc19.i686.PAE #1 SMP Tue
                              Jun 4 00:41:36 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-06-08 17:51:18 YEKT
Last Seen                     2013-06-08 17:51:18 YEKT
Local ID                      5975650d-a174-4251-a621-c4db99b34ab1

Raw Audit Messages
type=AVC msg=audit(1370692278.49:598): avc:  denied  { execheap } for  pid=7708 comm="steam" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1370692278.49:598): arch=i386 syscall=mprotect success=no exit=EACCES a0=cbb0000 a1=c000 a2=7 a3=bfa29ecc items=0 ppid=7623 pid=7708 auid=1000 uid=1000 gid=0 euid=1000 suid=1000 fsuid=1000 egid=0 sgid=0 fsgid=0 ses=1 tty=pts4 comm=steam exe=/home/mikhail/.local/share/Steam/ubuntu12_32/steam subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)

Hash: steam,unconfined_t,unconfined_t,process,execheap

Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-301.fc19.i686.PAE
type:           libreport

Potential duplicate: bug 894788

Comment 1 Miroslav Grepl 2013-06-12 07:43:38 UTC

*** This bug has been marked as a duplicate of bug 894788 ***


Note You need to log in before you can comment on or make changes to this bug.