Bug 972355 - Add support for EFI operating systems in mkconfig
Add support for EFI operating systems in mkconfig
Status: CLOSED DUPLICATE of bug 873207
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 15:56 EDT by Matthew Garrett
Modified: 2013-11-26 15:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 19:17:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add EFI operating systems to the menu (800 bytes, patch)
2013-06-08 15:56 EDT, Matthew Garrett
no flags Details | Diff

  None (edit)
Description Matthew Garrett 2013-06-08 15:56:35 EDT
Created attachment 758622 [details]
Add EFI operating systems to the menu

UEFI operating systems don't get added to the boot menu, which is a pain. This patch adds rough support.
Comment 1 Adam Williamson 2013-06-10 18:13:35 EDT
any objection to making this a dupe of 873207? it's the same issue and a lot of interested parties are subscribed to that one.
Comment 2 Matthew Garrett 2013-06-10 18:18:05 EDT
No problem.
Comment 3 Adam Williamson 2013-06-10 19:17:03 EDT

*** This bug has been marked as a duplicate of bug 873207 ***
Comment 4 Michael Shigorin 2013-11-26 15:25:57 EST
In case anyone with 2.00 wonders:

+grub_tab="	"
+
+grub_add_tab () {
+  sed -e "s/^/$grub_tab/"
+}

Thank you Matthew :)

Note You need to log in before you can comment on or make changes to this bug.