Bug 972356 - REGRESSION: pre_build hook no longer called on jbosseap
REGRESSION: pre_build hook no longer called on jbosseap
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
: 971761 974354 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 15:57 EDT by Clayton Coleman
Modified: 2015-05-14 19:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:46:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-06-08 15:57:17 EDT
Appears pre_build no longer invoked - intentional, or accidental?

https://github.com/Athou/commafeed/issues/269
Comment 1 Clayton Coleman 2013-06-08 15:57:31 EDT
During maven builds that is.
Comment 2 Mrunal Patel 2013-06-12 15:20:03 EDT
Added some logs. We are not determining the primary cartridge correctly in the build code.

Writing objects: 100% (3/3), 286 bytes, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_stop
_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_stop
_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_sto
p_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_sto
p_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_stop
_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_stop
_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_sto
p_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_sto
p_mysql-5.1 exists
remote: Stopping jbosseap cart
remote: Sending SIGTERM to jboss:8573 ...
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_pre$repo-archive_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_pre$repo-archive_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_pr$-repo-archive_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_pr$-repo-archive_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_upd$te-configuration_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_upd$te-configuration_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_up$ate-configuration_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_up$ate-configuration_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_pre$build_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_pre$build_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_pr$-build_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_pr$-build_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_bui$d_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/pre_bui$d_mysql-5.1 exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_bu$ld_mysql exists
remote: Checking if /var/lib/openshift/51b8b9f7d2962d0ceb000005/app-root/runtime/repo/.openshift/action_hooks/post_bu$ld_mysql-5.1 exists
Comment 4 chunchen 2013-06-14 07:36:39 EDT
It's fixed, verified on devenv_stage_375, please refer to the following results:

1. Create a jbosseap app with mysql and mongodb
rhc app create ceap01 jbosseap-6.0 mysql-5.1 mongodb-2.2
2. Add pre_build hooks for cartridges
echo 'echo "CCCCCCCCCCCCC-TEST, IN Pre-build of jbosseap-6.0"' > .openshift/action_hooks/pre_build_jbosseap-6.0
echo 'echo "CCCCCCCCCCCCC-TEST, IN Pre-build of mongodb-2.2"' > .openshift/action_hooks/pre_build_mongodb-2.2
echo 'echo "CCCCCCCCCCCCC-TEST, IN Pre-build of mysql-5.1"' > .openshift/action_hooks/pre_build_mysql-5.1
git add .; git commit -amp; git push

[master 7a7715f] p
 Committer: chunchen <chunchen@ex-elb1-prod-1847871222.us-east-1.elb.amazonaws.com>
Your name and email address were configured automatically based
on your username and hostname. Please check that they are accurate.
You can suppress this message by setting them explicitly:

    git config --global user.name "Your Name"
    git config --global user.email you@example.com

After doing this, you may fix the identity used for this commit with:

    git commit --amend --reset-author

 3 files changed, 3 insertions(+)
 create mode 100644 .openshift/action_hooks/pre_build_jbosseap-6.0
 create mode 100644 .openshift/action_hooks/pre_build_mongodb-2.2
 create mode 100644 .openshift/action_hooks/pre_build_mysql-5.1
Warning: Permanently added 'ceap01-cdm.dev.rhcloud.com,54.226.210.66' (RSA) to the list of known hosts.
Counting objects: 10, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (7/7), done.
Writing objects: 100% (7/7), 846 bytes, done.
Total 7 (delta 0), reused 0 (delta 0)
remote: Stopping jbosseap cart
remote: Sending SIGTERM to jboss:4431 ...
remote: CCCCCCCCCCCCC-TEST, IN Pre-build of jbosseap-6.0
remote: Found pom.xml... attempting to build with 'mvn -e clean package -Popenshift -DskipTests'
remote: Apache Maven 3.0.3 (r1075437; 2011-06-20 13:22:37-0400)
remote: Maven home: /etc/alternatives/maven-3.0
remote: Java version: 1.7.0_19, vendor: Oracle Corporation
remote: Java home: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.19/jre
remote: Default locale: en_US, platform encoding: ANSI_X3.4-1968
remote: OS name: "linux", version: "2.6.32-358.11.1.el6.x86_64", arch: "i386", family: "unix"
remote: [INFO] Scanning for projects...
remote: [INFO]                                                                         
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Building ceap01 1.0
remote: [INFO] ------------------------------------------------------------------------
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/org/apache/maven/plugins/maven-clean-plugin/2.4.1/maven-clean-plugin-2.4.1.pom
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-clean-plugin/2.4.1/maven-clean-plugin-2.4.1.pom
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-clean-plugin/2.4.1/maven-clean-plugin-2.4.1.pom (5 KB at 3.4 KB/sec)
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/org/apache/maven/plugins/maven-plugins/18/maven-plugins-18.pom
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-plugins/18/maven-plugins-18.pom
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-plugins/18/maven-plugins-18.pom (13 KB at 352.7 KB/sec)
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/org/apache/maven/maven-parent/16/maven-parent-16.pom
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/maven-parent/16/maven-parent-16.pom
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/maven-parent/16/maven-parent-16.pom (23 KB at 757.6 KB/sec)
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/org/apache/apache/7/apache-7.pom
<------------snip----------->
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/xpp3/xpp3_min/1.1.4c/xpp3_min-1.1.4c.jar
remote: Downloading: http://maven.repository.redhat.com/techpreview/all/org/apache/maven/shared/maven-filtering/1.0-beta-2/maven-filtering-1.0-beta-2.jar
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/maven-archiver/2.4.1/maven-archiver-2.4.1.jar
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/codehaus/plexus/plexus-archiver/1.2/plexus-archiver-1.2.jar
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/codehaus/plexus/plexus-io/1.0.1/plexus-io-1.0.1.jar
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/com/thoughtworks/xstream/xstream/1.3.1/xstream-1.3.1.jar
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/xpp3/xpp3_min/1.1.4c/xpp3_min-1.1.4c.jar
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/maven-archiver/2.4.1/maven-archiver-2.4.1.jar (20 KB at 332.6 KB/sec)
remote: Downloading: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/shared/maven-filtering/1.0-beta-2/maven-filtering-1.0-beta-2.jar
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/codehaus/plexus/plexus-io/1.0.1/plexus-io-1.0.1.jar (50 KB at 752.6 KB/sec)
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/xpp3/xpp3_min/1.1.4c/xpp3_min-1.1.4c.jar (25 KB at 329.3 KB/sec)
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/shared/maven-filtering/1.0-beta-2/maven-filtering-1.0-beta-2.jar (33 KB at 327.3 KB/sec)
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/org/codehaus/plexus/plexus-archiver/1.2/plexus-archiver-1.2.jar (178 KB at 1131.1 KB/sec)
remote: Downloaded: http://mirror1.ops.rhcloud.com:80/nexus/content/groups/public/com/thoughtworks/xstream/xstream/1.3.1/xstream-1.3.1.jar (422 KB at 2327.6 KB/sec)
remote: [INFO] Packaging webapp
remote: [INFO] Assembling webapp [ceap01] in [/var/lib/openshift/264557389311958553985024/app-root/runtime/repo/target/ceap01]
remote: [INFO] Processing war project
remote: [INFO] Copying webapp resources [/var/lib/openshift/264557389311958553985024/app-root/runtime/repo/src/main/webapp]
remote: [INFO] Webapp assembled in [112 msecs]
remote: [INFO] Building war: /var/lib/openshift/264557389311958553985024/app-root/runtime/repo/deployments/ROOT.war
remote: [INFO] WEB-INF/web.xml already added, skipping
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] BUILD SUCCESS
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Total time: 48.603s
remote: [INFO] Finished at: Fri Jun 14 07:16:15 EDT 2013
remote: [INFO] Final Memory: 11M/27M
remote: [INFO] ------------------------------------------------------------------------
remote: Deploying JBoss
remote: Starting jbosseap cart
remote: Found 127.0.250.129:8080 listening port
To ssh://264557389311958553985024@ceap01-cdm.dev.rhcloud.com/~/git/ceap01.git/
   3c7ae73..7a7715f  master -> master
Comment 5 Mrunal Patel 2013-06-14 15:56:57 EDT
*** Bug 974354 has been marked as a duplicate of this bug. ***
Comment 6 Dan Mace 2013-06-17 15:28:19 EDT
*** Bug 971761 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.