This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 972365 - packstack didn't install openstack-nova-compute on the defined compute node
packstack didn't install openstack-nova-compute on the defined compute node
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity urgent
: snapshot2
: 3.0
Assigned To: Martin Magr
Brandon Perkins
Test Blocker
: Regression, Triaged
Depends On:
Blocks: 966325
  Show dependency treegraph
 
Reported: 2013-06-08 18:16 EDT by Rami Vaknin
Modified: 2014-01-12 18:55 EST (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.14.dev622
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 14:53:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 32374 None None None Never

  None (edit)
Description Rami Vaknin 2013-06-08 18:16:27 EDT
Version:
Grizzly on rhel6.4, puddle 2013-06-07.1, openstack-packstack-2013.1.1-0.13.dev621.el6ost

Description:
I've installed two machines environment with packstack, one of them is the compute node, the second one is OpenStack Networking + OVS + l3 + dhcp + other services.
CONFIG_NOVA_COMPUTE_HOSTS=ip_of_the_compute_node

Result:
openstack-nova-compute was not installed on the compute node

10.35.160.25_nova.pp.log
========================
Invalid db connection mysql://nova@10.35.160.23/nova at /var/tmp/packstack/c4b5d5e5bfeb4820b943aca526f63ec1/modules/nova/manifests/init.pp:153 on node ...


Maybe due to commit 621822bed73b5ad0fbe6b0de9f2857c9966c8c04 ???
Comment 1 Martin Magr 2013-06-10 09:47:47 EDT
openstack-packstack-2013.1.1-0.14.dev622
Comment 6 errata-xmlrpc 2013-06-11 14:53:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0938.html

Note You need to log in before you can comment on or make changes to this bug.