Bug 972448 - [User experience] User experience unbearable, when user login to User Portal with 1800 VM's.
[User experience] User experience unbearable, when user login to User Portal ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Aharon Canan
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 09:44 EDT by vvyazmin@redhat.com
Modified: 2014-01-16 09:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 09:37:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvyazmin@redhat.com 2013-06-09 09:44:20 EDT
Description of problem: User experience unbearable, when user login to User Portal with 1800 VM's.

Version-Release number of selected component (if applicable):
RHEVM 3.2 - SF17.1 environment: 

RHEVM: rhevm-3.2.0-11.28.el6ev.noarch 
VDSM: vdsm-4.10.2-21.0.el6ev.x86_64 
LIBVIRT: libvirt-0.10.2-18.el6_4.5.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.3.x86_64 
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
Build on BZ880969 scenario
1. On iSCSI DC create 1800 VM's
2. All VM's in “Down” state
3. Add user to “Permissions” management with “PowerUserRole” role, to all those VM's.
4. Login with this user to User Portal
  
Actual results:
1. User experience unbearable, browser try demonstrate all 1800 objects (vm's) on user session
2. Browser Firefox – same time crashed,  browser Chrome same time stuck.
3. All works very slowly
4. No option scroll but fixed mount VM's is possible
5. Same experience I get via “Basic” and “Extended” view

Expected results:
User can get normal user experience

Impact on user:

Workaround:

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 1 Itamar Heim 2013-06-09 10:23:46 EDT
user portal is not meant for users with 1800 VMs.
does this reproduce with user with permissions for 50 VMs? 100 VMs? 200 VMs?
Comment 3 vvyazmin@redhat.com 2013-08-08 07:12:08 EDT
It's reproduce with 150 and more VM's, because in UI of User Portal browser try draw all those objects in one page.
IMHO it should be divided by pages with 100 VM's or less, same idea as in WebAdmin Portal.
Comment 7 Einav Cohen 2014-01-16 09:37:19 EST
I really don't think that it is worth looking into - closing.

Note You need to log in before you can comment on or make changes to this bug.