Bug 972458 - kickstart ks= kernel command line options are documented incorrectly
kickstart ks= kernel command line options are documented incorrectly
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Pete Travis
Petr Bokoc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 11:03 EDT by Jeff Layton
Modified: 2014-06-18 03:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 06:05:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2013-06-09 11:03:44 EDT
Table 11.2 on this page seems to have the wrong syntax listed for ks= options:

http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/sn-automating-installation.html#tb-kssources

It says:

    ks=hd:/device/directory/ks.cfg

...but really, it should be:

    ks=hd:device:/directory/ks.cfg

...I think the others are similarly incorrect, but don't have a good way to confirm that at the moment.
Comment 2 Pete Travis 2013-06-18 01:28:46 EDT
I've removed the cited '/' from the table [1], as per the wiki page maintained by the anaconda team [2]._Kickstart_Options . The other entries in the the table appear correct, and this looks like the only instance where "ks=hd" had the leading slash. Thanks for reporting, Jeff!

[1] https://git.fedorahosted.org/cgit/docs/install-guide.git/commit/?id=15a915e24e43ffbad9d15957f313091e33b2a50a
[2] http://fedoraproject.org/wiki/Anaconda/Kickstart#Chapter_2
Comment 3 Petr Bokoc 2013-09-17 06:05:22 EDT
Verified in the current F19 version available at docs.fp.o.

Note You need to log in before you can comment on or make changes to this bug.