Bug 972471 - Pavilion g4-1260la: Suspend fails, display stays black on resume
Pavilion g4-1260la: Suspend fails, display stays black on resume
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 12:05 EDT by Vladimir Hidalgo
Modified: 2013-10-08 13:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 13:13:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of last suspend (9.12 KB, text/x-log)
2013-06-09 12:05 EDT, Vladimir Hidalgo
no flags Details

  None (edit)
Description Vladimir Hidalgo 2013-06-09 12:05:15 EDT
Created attachment 758855 [details]
Log of last suspend

Description of problem:
On resume after suspend, display stays black, everything else works and I know it because if I left any music playing it will continue to play back on resume, it's just I can't see anything.

There are like 6 bugs similar to this but are as old as Fedora 9 and all are "CLOSED WONTFIX" without any solution. 

Version-Release number of selected component (if applicable):
Fedora 19?

How reproducible:
Always

Steps to Reproduce:
1. pm-suspend
2. try to resume, get black screen
3. reboot the system as you can't recover

Actual results:
black screen after resume

Expected results:
Colorful and vibrant colors on my display


Additional info:
This is sad because I installed Fedora 18 (then upgraded to 19) to my GF because "Linux was great, you won't regret" and now she can't adjust brightness neither suspend her laptop.

What worries me is that this bug seems to be present as old as 2009, I don't know if it's even worth the time to report.
Comment 1 Jaroslav Škarvada 2013-06-14 06:31:50 EDT
It seems there are some quirks for your machine in the quirks db which cannot be run because there is no vbetool. Could you try to install vbetool?

# yum install vbetool

However, the pm-utils is getting deprecated in the latest fedoras. The suspend is handled by systemd. It should work out of the box without the quirks.

In case you are able to correctly suspend / resume without X (i.e. from something previously called runlevel 3), please file a bug on the Xorg driver for you graphic. If it doesn't work correctly even without X, please file a bug on the kernel.
Comment 2 Vladimir Hidalgo 2013-07-07 20:00:19 EDT
Thanks for your input, it seems vbetool can't be installed anymore via yum.

I'm doing yum upgrade right now and will test and report back as soon as finished.
Comment 3 Vladimir Hidalgo 2013-07-07 22:22:23 EDT
Upgraded to F19 and did not work, after it I installed vbetool from a F17 rpm and now it not longer warns about vbetool not installed but still resume does not work.

Also I still can't change brightness.
Comment 4 Jaroslav Škarvada 2013-07-08 03:53:43 EDT
This is probably not pm-utils fault.

We need to find out whether it is kernel fault or Xorg video driver fault (my guess is the latter).

1) Try to suspend from the terminal. Run by root:

# echo mem > /sys/power/state

2) Switch to runlevel 3 (i.e. the mode without X):

# telinit 3
Login as root.
# echo mem > /sys/power/state

If 1) fails and 2) works OK it is very probably the Xorg video driver.
If both fails it is very probably the kernel.
Comment 5 Vladimir Hidalgo 2013-07-13 22:24:48 EDT
Sorry for slow reply, I've to borrow my GF laptop to test.

I tried both and neither worked out, both fails in the exact same way. I just updated to latest 13-Jun-2013 packages before running the test.

Should I fill a bug against kernel package?. Do you need any log file to debug it?.

Thank you for your help.
Comment 6 Jaroslav Škarvada 2013-07-15 04:34:19 EDT
(In reply to Vladimir Hidalgo from comment #5)
OK, thanks for info, reassigning to kernel. I think it would be helpful if you could provide the output of the dmesg command after the wrong resume (e.g. grab it through the ssh).
Comment 7 Josh Boyer 2013-09-18 16:31:35 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 8 Josh Boyer 2013-10-08 13:13:03 EDT
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 2 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.

Note You need to log in before you can comment on or make changes to this bug.