Bug 97249 - (SCSI SYM53C8XX)sym53c875-1 command filed - Using Tape Backup
Summary: (SCSI SYM53C8XX)sym53c875-1 command filed - Using Tape Backup
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-11 21:39 UTC by James Shanks
Modified: 2007-04-18 16:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-23 13:47:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modules.conf as requested (98 bytes, text/plain)
2003-06-23 13:34 UTC, James Shanks
no flags Details

Description James Shanks 2003-06-11 21:39:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I recently upgraded (clean install) a server from RedHat Linux 8.0 to 9x.  Tape
backup software (NovaNET 8.5 SP3) now runs extremely slow and the messages log
file has the follow errors repeated every 5 minutes:

Jun 11 16:05:54 keys kernel: sym53c875-1-<6,0>: extraneous data discarded.
Jun 11 16:05:54 keys kernel: sym53c875-1-<6,0>: COMMAND FAILED (89 0) @d7d13000.

Seems to be a problem with the Symbios SCSI controller driver.

The controller and tape drive (in fact the entire system) worked fine under RH
7.3 and RH 8.0 with kernel 2.4.20.

I also have another system that was recently upgraded to RedHat 9 with an
Adaptec SCSI adapter the runs just fine.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.20-18.9

How reproducible:
Always

Steps to Reproduce:
1.  Install RedHat Linux 9 on a system with a Symbios SCSI controller
2.  Install NovaNET Tape Backup software (demo available from novastor)
3.  Perform bakup.
    

Actual Results:  Backup eventually completes, but at a rate less than 1Mb per
minute (typical before was about 65Mb per minute).  Status of backup is not
displayed during the backup which may be due to the invalid command to the SCSI
controller.  Same machine with 2.4.20 kernel with RedHat Linux 8.0 ran fine.

Expected Results:  NovaNET should perform with SymBIOS SCSI controller as well
as it did with either an Adaptec controller or with RedHat Linux 8.0.

Additional info:

Comment 1 Alan Cox 2003-06-22 18:09:52 UTC
Can you attach your /etc/modules.conf so I can see which driver it is picking


Comment 2 James Shanks 2003-06-23 13:34:53 UTC
Created attachment 92555 [details]
modules.conf as requested

Comment 3 James Shanks 2003-06-23 13:43:06 UTC
I submitted this bug to NovaStor as well.  A recent patch to NovaNET from
NovaStor solved the problem.  I'm not sure if this means that the bug doesn't
exits, but for me everything is working now.

Resolution:  Install NovaNET 8.50 SP3E


Comment 4 Alan Cox 2003-06-23 13:47:14 UTC
Ok that makes sense - the driver is logging a failure because the requester
(probably the novastor tool) sent a command and expected less reply bytes than
it got.

The older driver wasnt smart enough to realise this was an error



Note You need to log in before you can comment on or make changes to this bug.