Bug 97251 - hyperball hangs ThinkPad T40
hyperball hangs ThinkPad T40
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 17:43 EDT by Joe Harrington
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 12:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 2003-06-11 17:43:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Running the hyperball screensaver, even in a window (i.e., not as a
screensaver), hangs my IBM ThinkPad T40 laptop.  This happens even when the
screensaver is run as a regular user, usually after 10 seconds - 3 minutes of
run.  Everything is normal until then, including a constant amount of process
memory.

Other mild weirdness: there is junk in the hyperball window after the hyperball
starts rolling.  It seems to be unerased lines from the initial screen.  It
doesn't get worse.

Version-Release number of selected component (if applicable):
xscreensaver-4.07-2

How reproducible:
Always

Steps to Reproduce:
1.enter /usr/X11R6/lib/xscreensaver/hyperball to a command prompt
2.wait a few minutes


Actual Results:  - everything is normal until the machine crashes
- ps auxw | grep hyper indicates no growth at all in the memory used by the process
- when the machine crashes, the screen contents remain unchanged
- the keyboad does not respond to any set of keystrokes, including caps lock,
ctrl-alt-delete/backspace/F1-F12, Fn-anything.  Only holding down the power
"key" produces the response of turning off the power.
- the mouse does not move
- network connections to the machine die
- the machine is unpingable
- there are no log messages
- there is no core dump
- if the machine is pinged, the traffic light next to the ethernet socket does
blink once per ping.  This and the fan are the only signs of life...

Expected Results:  Just the normal hyperball rolling around.  No crash!

Additional info:

IBM ThinkPad T40 model 2373-92U
1400x1050 screenadeo
ATI Radeon Mobility 9000 graphics adapter
Red Hat 9 with updates through 28 May 2003
xscreensaver-4.07-2
XFree86-4.3.0-2, using radeon driver

Workaround: remove hyperball from the random screensaver list.

I've marked this as high severity because the default screensaver is a random
selection that will eventually find the hyperball and crash the machine.  Users
who leave their laptop running find it crashed while they're gone.

Of course, I suspect the problem is in XFree86 or the radeon driver, but I can't
be sure.  Perhaps it has to do with the handling of 1-pixel lines.  All the
other screensavers work fine, including the GLX ones.  I don't know if hyperball
uses GLX.

--jh--
Comment 1 Bill Nottingham 2003-06-11 18:50:11 EDT
Hm, it's been running fine for an hour here on a T40p. Assigning to X - note
that hyperball is not a glx screensaver.
Comment 2 Joe Harrington 2003-06-12 20:27:29 EDT
The T40p and the T40 have different graphics subsystems.  The T40p has an ATI
Mobility FIRE GL 9000 with 64 MB and the T40 (or at least the 237392U model) has
an ATI Mobility RADEON 9000 with 32 MB.

Let me know if I should send configuration things like the kind of focus (I use
follow-pointer, though I don't see how this would matter given that it crashes
in the middle of the night when I'm not using it).

--jh--
Comment 3 Sarah Gordon 2003-12-03 19:35:22 EST
I see the same behavior on my Dell Inspiron 8500.  Please let me know
if there is additional information that I can provide.

$ lspci |grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[Radeon Mobility 9000] (rev 01)
Comment 4 Joe Harrington 2003-12-04 10:00:30 EST
I have the same adapter, different rev:

lspci |grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[Radeon Mobility 9000] (rev 02)

Hey Red Hat folks, any chance of work here?  If not, is there another
place we can report this?  Might ATI help?

Sarah, what version of XFree86 are you running?  What kernel?

Thanks,

--jh--
Comment 5 Sarah Gordon 2003-12-04 13:11:13 EST
Responding to the questions above:

$ XFree86 -version

XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-3bigmem i686 [ELF] 
Build Date: 27 February 2003
Build Host: porky.devel.redhat.com
 
        Before reporting problems, check http://www.XFree86.Org/
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.20-18.9
(bhcompile@porky.devel.redhat.com) (gcc version 3.2.2 20030222 (Red
Hat Linux 3.2.2-5)) #1 Thu May 29 07:08:16 EDT 2003 P


Per the above, the kernel version is 2.4.20-18.9

$ rpm -qi kernel-2.4.20-18.9
Name        : kernel                       Relocations: (not relocateable)
Version     : 2.4.20                            Vendor: Red Hat, Inc.
Release     : 18.9                          Build Date: Thu 29 May
2003 04:15:12 AM PDT
Install Date: Sun 13 Jul 2003 12:03:19 PM PDT      Build Host:
porky.devel.redhat.com
Group       : System Environment/Kernel     Source RPM:
kernel-2.4.20-18.9.src.rpm
Size        : 32167682                         License: GPL
Signature   : DSA/SHA1, Mon 02 Jun 2003 08:34:45 AM PDT, Key ID
219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : [...]
Comment 7 Mike A. Harris 2004-09-01 12:56:11 EDT
hyperball seems to work fine on radeon hardware with our current
rawhide xorg-x11.  Please test this, and if you still experience
the problem on mobile radeon chips, please file a bug report upstream
at http://bugs.freedesktop.org in the 'xorg' component, with full
details, and paste the upstream URL here, and we will track the
issue upstream.

Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.