Bug 97252 - "neat" and "redhat-config-network" no longer work after some package upgrades
"neat" and "redhat-config-network" no longer work after some package upgrades
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2003-06-11 17:44 EDT by Brett L. Becker
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-06-04 05:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
the error dialog (1.75 KB, application/octet-stream)
2003-06-11 17:45 EDT, Brett L. Becker
no flags Details
new error dump (1.04 KB, application/octet-stream)
2003-06-16 07:45 EDT, Brett L. Becker
no flags Details

  None (edit)
Description Brett L. Becker 2003-06-11 17:44:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030610 Galeon/1.3.5

Description of problem:
"neat" and "redhat-config-network" both run fine, of course, on a fresh install
of RH9.  But after some upgrading (using apt-rpm) from the RH9-updates section
of http://ftp-stud.fht-esslingen.de/apt/redhat/ and some updates of gnome from
http://people.ecsc.co.uk/~matt/downloads/apt/redhat-9-i386/ , neither of these
two commands does anything except dump an error:

[brett@Miles brett]$ neat
** (redhat-config-network-gui:2131): WARNING **:
 --- you're entering a whole world of pain ---
(redhat-config-network:2131): GLib-GObject-WARNING **: gobject.c:946: object
class `GnomeProgram' has no property named `default-icon'

redhat-cofig-network then fails to load, and an error dialog pops up containing
the error that I've attached to this report.  Note that the error in the
attachment is from the rawhide version of redhat-config-network.  It's the same
when using the RH9 version.

I don't really know what is wrong... I've played with upgrading and downgrading
my gnome2-python, python2, libxml2, libxml2-python, pygtk packages... to no avail.

What I have *not* tried is downgrading to glib2-2.2.1-x, as this will break
almost all of the rest of gnome... I'm running development packages.  By the
look of the first warning, it seems that this might be an issue.  I've used both
the rawhide and independent builds of glib2-2.2.2-1, and the results are the same.

All the other redhat-config-x packages seem to work fine, though
redhat-config-services dumps the same error as above at the terminal, but then
runs fine.

I'm about out of ideas.


Version-Release number of selected component (if applicable):
redhat-config-network(-tui)-1.2.0-2, -1.3.0-1

How reproducible:

Steps to Reproduce:
1.either from a terminal or from the menu, run "redhat-config-network"
2.enter password for pam

Actual Results:  the errors reported in the description

Expected Results:  I should be able to see and change my network settings, yo!

Additional info:  see attachment
Comment 1 Brett L. Becker 2003-06-11 17:45:20 EDT
Created attachment 92348 [details]
the error dialog
Comment 2 Harald Hoyer 2003-06-16 07:24:09 EDT
better get the updates from:
Comment 3 Brett L. Becker 2003-06-16 07:44:30 EDT
Hello... and thanks for the updates.  I removed the old versions and installed
the new ones fresh, and --force 'd rhpl because I was using the rawhide version...

Tried to run redhat-config-network and it still fails... though it dumps a
different error this time.  I'll post an attachment.

This all seems to have to do with python, to me.  Any idea what is causing this?
 Just for reference, these are the versions I'm running:


I've tried with rawhide python and rawhite gnome-python2 packages, and still it
fails.  This is frustrating because r-c-n is a great program.

Comment 4 Brett L. Becker 2003-06-16 07:45:30 EDT
Created attachment 92416 [details]
new error dump
Comment 5 Brett L. Becker 2003-06-29 13:26:30 EDT
This seems to be fixed in the newest version of redhat-config-network.  Just
tried  1.3.1-1 and it runs fine all of a sudden.  I don't know what the problems
above were related to, but they seem to have gone away.  Rock on.

Comment 6 Harald Hoyer 2004-06-04 05:58:23 EDT
Closing due to inactivity. Reopen, if the problem is still existing.

Note You need to log in before you can comment on or make changes to this bug.