Bug 972536 - Some symbols are hidden, but pkgconfig reports old version
Some symbols are hidden, but pkgconfig reports old version
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: assimp (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rich Mattes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 18:42 EDT by Scott K Logan
Modified: 2013-07-16 23:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: assimp-2.0.863-10.20110824svn.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 23:12:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott K Logan 2013-06-09 18:42:15 EDT
Description of problem:
Line 21 of the CMakeLists.txt for assimp causes some symbols to be hidden. This behaviour was introduced at svn revision 1069 of assimp (see https://assimp.svn.sourceforge.net/svnroot/assimp/trunk/CMakeLists.txt?p=1069), however the assimp.pc does not reflect the version change until svn revision 1255 (see https://assimp.svn.sourceforge.net/svnroot/assimp/trunk/CMakeLists.txt?p=1255).

Therefore, we are stuck in limbo, where we are unable to detect (in dependant projects) if the symbols are hidden in assimp or not.

Also, the SVN revision indicated by the SPEC file is 1071, while the "patch" version number indicated is 863. I'm not sure, but I believe that assimp uses svn revision as the "patch" version, so the version number of the currently deployed release may be behind.


Version-Release number of selected component (if applicable):
2.0.863-8.20110824svn.fc19

How reproducible:
100%

Steps to Reproduce:
1. View the assimp.pc
2. View the CMakeLists.txt
3. View the assimp.spec

Actual results:
assimp.pc does not reflect version change (reports 2.0 instead of 2.0.1071)

Expected results:
Version change is reflected in assimp.pc and therefore dependant projects know that the symbols are hidden in this version of assimp.

Additional info:
The solution is simply to upgrade to 1255 of assimp or to patch the CMakeLists.txt file to update the assimp.pc file to reflect the "patch" version so this change may be detected.
Comment 1 Rich Mattes 2013-06-28 22:47:52 EDT
So if memory serves me correctly, assimp 2.0.853 was the last "released" version of the assimp 2.0 series, downloadable on their sourceforge project page.  However, 1071 was the first SVN revision where they split their models between free and nonfree, which allowed me to delete the non-free models and submit the package to Fedora.  This is why the SVN snapshot is packaged instead of the last released -863 version.

SVN revision 1255 is quite different from rev 1071 that is packaged, and is really much closer to assimp 3.0 (which is svn revision 1270) than assimp 2.0.  Indeed, it looks like most of the patches do not apply cleanly to svn revision 1255, so it will take some time if I go that route.  For this reason, I think I would prefer just setting the patch version of the current package to 1071 in CMakeLists.txt for f19 and lower, and rebuilding.  Is this satisfactory, or would you rather see the package upgraded?
Comment 2 Scott K Logan 2013-06-29 17:10:40 EDT
That will solve my issue, thank you! By the way, I discovered this while compiling ROS Groovy for F19 - AFAIK, it is the only problem in the entire process. Thanks for your help here, I'll submit a patch to ROS to fix their end of this issue as well!
Comment 3 Rich Mattes 2013-07-05 17:39:57 EDT
Alright I'll go ahead and update the patch version in CMakeLists.txt.  We're about halfway through getting the fuerte base packages into Fedora, and hope to get to groovy in to f20, so this should definitely help.
Comment 4 Fedora Update System 2013-07-05 18:52:12 EDT
assimp-2.0.863-10.20110824svn.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/assimp-2.0.863-10.20110824svn.fc19
Comment 5 Fedora Update System 2013-07-06 21:39:32 EDT
Package assimp-2.0.863-10.20110824svn.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing assimp-2.0.863-10.20110824svn.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12532/assimp-2.0.863-10.20110824svn.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-07-16 23:12:27 EDT
assimp-2.0.863-10.20110824svn.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.