Bug 972562 - EWS support fails with horde server backend
EWS support fails with horde server backend
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 01:06 EDT by Jason Haar
Modified: 2013-11-25 23:25 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 23:25:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Haar 2013-06-10 01:06:26 EDT
Description of problem:

The current release of Horde contains EWS support - which I can confirm works just fine with the "Exchange" account option in the Win8 native Mail app

evolution-ews apparently insists on doing an autodiscover lookup - which is a bit broken I think with Horde. However, as I chose "custom", I think that means "manual" doesn't it?

Version-Release number of selected component (if applicable):


How reproducible:

Try to set up an Exchange online account against a horde web server

Steps to Reproduce:
1. it just insists on doing the autodiscover - which will fail
2.
3.

Actual results:

Gives the following error

Failed to find ASUrl and OABUrl in autodiscover response

Expected results:

As I chose a "Custom", I think it should disable autodiscover and just go with the details I gave it.

Additional info:
Comment 1 Milan Crha 2013-06-10 06:08:03 EDT
Thanks for a bug report. You can check what autodiscover returned, if you run evolution from a console like this:

   $ EWS_DEBUG=2 evolution

and then repeat the "Fetch URL" button click, but I'm afraid it'll just for a little debugging of Horde, rather than of debugging evolution-ews itself.

In any case, the "Fetch URL" click is not necessary, you can always file the URLs for the EWS protocol and if you know then also for the OAB yourself. It's true, there was a bug [1] with this non-clicking 'Fetch URL', but it is fixed since evolution-ews-3.7.92, thus 3.8.0 stable release.

As you have this filled against Fedora 19, I suppose you do have at least 3.8.0, right?

> As I chose a "Custom", I think it should disable autodiscover and just go
> with the details I gave it.

I'm sorry, but I do not know what you mean with the above. What 'custom' do you mean, please? The autodiscover process is not necessary, you can even keep the OAB URL empty, that is no problem. The autodiscover is there to make life easier for a user, to not dig for the exact URLs on their own, but it's not a mandatory step in any way. Maybe if you can explain more precisely what "fails with horde", what exactly you did, what evolution claims, then it'll be easier to help.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=695311
Comment 2 Jason Haar 2013-11-25 23:25:17 EST
sorry, I never saw your followup until now.

I have since discovered horde doesn't support EWS - it only supports ActiveSync. So this is not going to work after all and it's not a bug with evolution

Jason

Note You need to log in before you can comment on or make changes to this bug.