Bug 972581 - [RHSC-SHELL] list events gives unknown error
Summary: [RHSC-SHELL] list events gives unknown error
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli   
(Show other bugs)
Version: 2.1
Hardware: Unspecified Unspecified
medium
high
Target Milestone: ---
: RHGS 2.1.2
Assignee: Aravinda VK
QA Contact: RamaKasturi
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 957769
TreeView+ depends on / blocked
 
Reported: 2013-06-10 07:22 UTC by RamaKasturi
Modified: 2015-05-13 16:29 UTC (History)
9 users (show)

Fixed In Version: 2.1.2.0-0.2 CB6
Doc Type: Bug Fix
Doc Text:
Previously, list events --show-all command in rhsc-shell was displaying error. Now, with this update, the events are listed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 07:29:59 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (74.33 KB, text/plain)
2013-10-31 08:27 UTC, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 12:20:30 UTC
oVirt gerrit 14323 None None None Never

Description RamaKasturi 2013-06-10 07:22:54 UTC
Description of problem:
list and show events gives error.

Version-Release number of selected component (if applicable):
rhsc-cli-2.1.0.0-1.bb1.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. login to rhsc-shell by typing the command ovirt-shell followed by connect --url https://10.70.35.155/api --user admin@internal --password redhat --insecure
2.Type the command list events --show-all 
3.

Actual results:
unknown error: 'datetime.datetime' object has no attribute '__dict__'


Expected results:
Should list the events with any exception.

Additional info:

Comment 1 RamaKasturi 2013-06-10 07:33:13 UTC
The following command also gives the same result as above.

1) list events --show-all

Comment 4 Aravinda VK 2013-09-16 06:58:42 UTC
Patch(http://gerrit.ovirt.org/#/c/14323/) available in upstream for the issue.

Comment 5 Scott Haines 2013-09-23 23:35:00 UTC
Targeting for 2.1.z U2 (Corbett) release.

Comment 6 RamaKasturi 2013-10-31 08:27:38 UTC
Created attachment 915798 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).

Comment 7 RamaKasturi 2013-10-31 08:30:32 UTC
Verified in CB6

Comment 8 Shalaka 2014-01-16 15:13:44 UTC
Please review the edited DocText and signoff.

Comment 9 Aravinda VK 2014-01-17 07:13:26 UTC
doc text looks good to me.

Comment 10 Aravinda VK 2014-01-17 07:15:30 UTC
minor update to doc text. Removed "show event" since separate bug addresses that issue.

Comment 12 errata-xmlrpc 2014-02-25 07:29:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html


Note You need to log in before you can comment on or make changes to this bug.