This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 972589 - [RHSC-SHELL] show event gives an unknown error.
[RHSC-SHELL] show event gives an unknown error.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Aravinda VK
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 03:39 EDT by RamaKasturi
Modified: 2015-05-13 12:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.1.2.0-0.2 CB6
Doc Type: Bug Fix
Doc Text:
Previously, show event command in rhsc-shell was displaying error. Now, with this update, the show event command displays the event information correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:30:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 11982 None None None Never

  None (edit)
Description RamaKasturi 2013-06-10 03:39:51 EDT
Description of problem:
Show event gives unknown error

Version-Release number of selected component (if applicable):
rhsc-cli-2.1.0.0-1.bb1.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. connect to rhsc-shell by typing the command ovirt-shell followed by connect --url https://10.70.35.155/api --user admin@internal --password redhat --insecure
2. Type the command show event --id 542 and press enter
3.

Actual results:
unknown error: cannot concatenate 'str' and 'int' objects


Expected results:
should show the event of the identifier given.

Additional info:
Comment 2 Aravinda VK 2013-09-16 03:02:20 EDT
Upstream Patch(http://gerrit.ovirt.org/#/c/11982) is available for this issue.
Comment 3 Scott Haines 2013-09-23 19:35:01 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 4 RamaKasturi 2013-10-31 04:29:51 EDT
Works fine in the build rhsc-cli-2.1.2.0-0.2.el6rhs.noarch.

The following ouput is displayed.

show event --id 234

id            : 234
description   : Installing Host 10.70.37.111. Yum Download/Verify: dmidecode-2.11-2.el6_1.x86_64.
cluster-id    : 7ec00300-0a7b-4d43-971a-2c7032202703
code          : 509
correlation_id: 3c5ebbde
custom_id     : -1
flood_rate    : 30
host-id       : 7cec04f3-f754-49f0-ae55-eb93e59c2778
origin        : oVirt
severity      : normal
time          : 2013-10-31 18:09:46.783000+05:30
Comment 5 RamaKasturi 2013-10-31 04:30:19 EDT
Verified in Build CB6
Comment 6 Shalaka 2014-01-16 10:10:00 EST
Please review the edited DocText and signoff.
Comment 7 Aravinda VK 2014-01-17 02:13:52 EST
doc text looks good to me.
Comment 9 errata-xmlrpc 2014-02-25 02:30:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.