Bug 972592 - Text install claims 'GNOME Desktop' is the default package set, but actually installs minimal (Final TC2)
Text install claims 'GNOME Desktop' is the default package set, but actually ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F19-accepted/F19FinalFreezeException
  Show dependency treegraph
 
Reported: 2013-06-10 03:47 EDT by Adam Williamson
Modified: 2013-06-28 03:17 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-blivet-0.17-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 03:17:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-06-10 03:47:43 EDT
I was testing a text mode netinstall of F19 Final TC2 (to test another bug), and noticed that although the 'hub' lists "GNOME Desktop" as the default package selection, if you don't go into the package selection at all but just complete the mandatory spokes and start an install, it is in fact 'minimal' which is installed. I haven't tested if installing GNOME actually works if you go in and explicitly select it.

Proposing as an FE as this is an obvious misleading inaccuracy which we ought to correct for Final.
Comment 1 Adam Williamson 2013-06-10 13:44:49 EDT
See also 972182 - not the same bug exactly, but likely related. It looks like the default label for this spoke is just stuck always being 'GNOME Desktop', no matter what the actual underlying configuration is.
Comment 2 Adam Williamson 2013-06-10 13:45:59 EDT
Discussed at 2013-06-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-10/f19final-blocker-review-4.2013-06-10-16.01.log.txt . Accepted as a freeze exception issue at least: this is clearly incorrect and misleading and should be fixed. There is some support for making it a blocker, but for now we decided to just accept it as FE and consider blocker status if we get closer to release and it isn't fixed.

Kamil says that you can get a GNOME install if you go into the spoke and explicitly select it.
Comment 3 Samantha N. Bueno 2013-06-19 16:55:39 EDT
Patch posted.
Comment 4 Samantha N. Bueno 2013-06-20 11:52:23 EDT
Patch pushed, commit c9fab0b9dafa3916c3d0ee1acd3c26a813309e79 (in f19-branch).
Comment 5 Fedora Update System 2013-06-24 17:59:57 EDT
anaconda-19.30.10-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30.10-1.fc19
Comment 6 Fedora Update System 2013-06-25 17:17:54 EDT
Package python-blivet-0.17-1.fc19, anaconda-19.30.11-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.11-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.11-1.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-26 13:10:50 EDT
Package python-blivet-0.17-1.fc19, anaconda-19.30.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.17-1.fc19 anaconda-19.30.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.12-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-28 03:17:59 EDT
python-blivet-0.17-1.fc19, anaconda-19.30.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.