Bug 97260 - USB problem with Pentax Optio cameras
USB problem with Pentax Optio cameras
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 04:20 EDT by Tim Waugh
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 2.4.20-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-17 20:55:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (27.30 KB, text/plain)
2003-06-13 04:42 EDT, Tim Waugh
no flags Details
/proc/bus/usb/devices (1.75 KB, text/plain)
2003-06-13 04:42 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2003-06-12 04:20:35 EDT
Description of problem:
USB Pentax Optio cameras (at least the S and the 430RS), which appear as mass
storage, cause 'mount' to go to D state.  Also, looking at /proc/scsi/scsi shows
'(null)'s to appear in several places (sorry, don't have it handy).

Version-Release number of selected component (if applicable):
2.4.20-18.9

How reproducible:
100%
Comment 1 Alexander Larsson 2003-06-12 04:25:18 EDT
I haven't looked at the details tim reported, but when i plug in my Pentax Optio
S camera all USB devices silently hang, including my mouse...
Comment 2 Pete Zaitcev 2003-06-12 14:59:09 EDT
I need a dmesg and <alt><sysrq>"t", taken after the lockup.
First, grab dmesg > /tmp/dmesg.out, because sysrq-t will overflow it.
Then, sysrq-t, and dmesg > /tmp/dmesg2.out. This may have enough
space to capture sysrq-t, or may not, depending.
Best of all do it from init runlevel 3, without X.
Fewer processes, less overlow.

Do not drop dmesgs into comments box, please. Attach them to
the bug instead.
Comment 3 Pete Zaitcev 2003-06-12 15:03:35 EDT
See also bug 89491. This reminds me, I need /proc/bus/usb/devices
for both cameras. Just make the OS limp somehow far enough to
capture that, so I can get vendor strings.
Comment 4 Tim Waugh 2003-06-13 04:42:09 EDT
Created attachment 92382 [details]
dmesg
Comment 5 Tim Waugh 2003-06-13 04:42:28 EDT
Created attachment 92383 [details]
/proc/bus/usb/devices
Comment 6 Tim Waugh 2003-06-13 04:43:06 EDT
With the camera, there are two mass storage devices on this machine; one is a
flash card reader on the printer.
Comment 7 Alan Cox 2003-06-22 14:08:26 EDT
The 330 is known to work with vanilla kernels, dunno about the 430RS. 430 is
also reported working with SuSE and idents added

http://www.chip.de/forum/thread.html?bwthreadid=382836
Comment 8 Pete Zaitcev 2003-07-28 17:08:18 EDT
The 0x0a17/0x0004 part is fixed upstream, I'm going to poke Arjan to take a patch.
Comment 9 Pete Zaitcev 2003-07-30 15:50:20 EDT
CVS 2.4.20-19+
It is in upstream, indeed.
Comment 10 Hardy Mayer 2003-08-20 21:53:49 EDT
Nicely fixed in kernel-2.4.20-20.9!
Thanks to all involved.
Comment 11 Pete Zaitcev 2003-09-17 20:55:41 EDT
Tim, don't forget to close 'modified' bugs, please.
Comment 12 Need Real Name 2004-03-03 13:08:41 EST
This is still broken for the Pentax Optio S.
Upgrading to 2.4.25 fixed it.

Note You need to log in before you can comment on or make changes to this bug.