Bug 972614 - emblem doesn't work properly with gvfs 1.14.2-4.fc18
emblem doesn't work properly with gvfs 1.14.2-4.fc18
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ondrej Holy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 04:31 EDT by Kazutoshi Morioka
Modified: 2014-02-05 18:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 18:11:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is my recent yum history output (28.12 KB, text/plain)
2013-06-10 11:26 EDT, Kazutoshi Morioka
no flags Details
And this is /var/log/yum.log (383.38 KB, text/plain)
2013-06-10 11:28 EDT, Kazutoshi Morioka
no flags Details

  None (edit)
Description Kazutoshi Morioka 2013-06-10 04:31:25 EDT
Description of problem:
After update to the mate-file-manager-1.6.1-4.fc18, emblem doesn't work properly.
When I drag and drop a emblem from sidebar to a file, the emblem is show up properly. Then, I drag and drop same emblem to a same file, the emblem is disappear as I want. But I drag and drop same emblem again, no emblem are shown up. And any operations about emblems are not work after this.
Emblems tab in the properties-dialogue shows same problem.
Any operation about emblems work only two times until restarting mate-file-manager.

Version-Release number of selected component (if applicable):
mate-file-manager-1.6.1-4.fc18

How reproducible:
Always

Steps to Reproduce:
1. Open file-manager
2. Select emblems sidebar
3. Drag drop a emblem to a file to set emblem
4. Drag drop a emblem to a file to clear emblem
5. Drag drop a emblem to a file again

another steps to reproduce:
1. Open file-manager
2. Right click a file and open properties-dialogue
3. Select emblems tab
4. Click a emblem icon to set emblem
5. Click a emblem icon to clear emblem
6. Click a emblem icon again

Actual results:
Nothing happen. No emblem was shown.

Expected results:
The emblem will be shown again.

Additional info:
Before update to 1.6.1-4.fc18, emblems worked perfectly.
I don't know whether this is related problem, sometimes mate-file-manager suddenly terminated when closing properties-dialogue after emblems-operation.
Comment 1 Wolfgang Ulbrich 2013-06-10 06:38:47 EDT
I can confirm this with 1.6.1-4.fc18.
Can post which version was working for you?
Also a complete yum log would be fine.
Do 'yum history', than 'yum history info <id>' from the update, and load up a attachment.
Comment 2 Kazutoshi Morioka 2013-06-10 11:26:24 EDT
Created attachment 759230 [details]
This is my recent yum history output

With my memory, mate-file-manager-1.5.5-1.fc18.x86_64 worked for me.
Comment 3 Kazutoshi Morioka 2013-06-10 11:28:13 EDT
Created attachment 759231 [details]
And this is /var/log/yum.log
Comment 4 Kazutoshi Morioka 2013-06-10 12:38:35 EDT
Sorry, but I confirmed that downgrade to the 1.5.1-1.fc18 don't fix this problem. And I found downgrade gvfs to the 1.14.2-3.fc18 fix this problem. I think this is a gvfs issue, not a mate-file-manager issue.

This is tested matrix.
gvfs version  | mate-file-manager | result 
1.14.2-4.fc18 | 1.6.1-4.fc18      | NG
1.14.2-4.fc18 | 1.5.1-1.fc18      | NG
1.14.2-3.fc18 | 1.6.1-4.fc18      | OK
1.14.2-3.fc18 | 1.5.1-1.fc18      | OK
Comment 5 Wolfgang Ulbrich 2013-06-10 13:48:43 EDT
Thank you!
i get same good results with 1.14.2-4.fc18.
Comment 6 Kazutoshi Morioka 2013-06-13 04:23:39 EDT
Fedora 19 has similar problem. Emblems can't be set nor clear. Should I file a separate bug report?
Comment 7 Wolfgang Ulbrich 2013-06-18 10:36:09 EDT
(In reply to Kazutoshi Morioka from comment #6)
> Fedora 19 has similar problem. Emblems can't be set nor clear. Should I file
> a separate bug report?

Yes this might be helpful.
Comment 8 Kazutoshi Morioka 2013-06-19 01:42:12 EDT
It seems that Fedora 19 has already fixed problem about emblems. Last night I tested Fedora 19 with latest gvfs and mate-file-manager and emblems are worked smoothly.
Comment 9 Dan Mashal 2013-06-19 01:44:07 EDT
Yes there were some dbus issues as well. I'll leave this open for a bit.
Comment 10 Wolfgang Ulbrich 2013-06-19 02:12:57 EDT
Dan,
the issue is cause by adding patches from gvfs-1.17 to f18 version.
All is writen in changelogs.
Comment 11 Dan Mashal 2013-06-19 02:21:00 EDT
I believe https://bugzilla.redhat.com/show_bug.cgi?id=975521 may or may not be related as well.
Comment 12 Fedora End Of Life 2013-12-21 10:33:20 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 13 Fedora End Of Life 2014-02-05 18:11:30 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.