Bug 972623 - jbpm-human-task-core tests fail on mssql due to: null id in org.jbpm.services.task.impl.model.TaskImpl entry
jbpm-human-task-core tests fail on mssql due to: null id in org.jbpm.services...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ER1
: 6.0.0
Assigned To: Mauricio Salatino
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 04:48 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins log (14.45 KB, text/plain)
2013-06-10 04:48 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-06-10 04:48:05 EDT
Created attachment 759112 [details]
jenkins log

jbpm-human-task-core tests fail on mssql2008R2 and mssql2012 due to:

Caused by: org.hibernate.AssertionFailure: null id in org.jbpm.services.task.impl.model.TaskImpl entry (don't flush the Session after an exception occurs)

See the whole attached stack trace from arbitrarily chosen test in jbpm-human-task-core. You can also go through the following or other jenkins build results:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix/DATABASE=mssql2008R2,MODULES=jbpm-human-task%2Fjbpm-human-task-core,jdk=java16_default,label=RHEL_any/

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix/DATABASE=mssql2012,MODULES=jbpm-human-task%2Fjbpm-human-task-core,jdk=java16_default,label=RHEL_any/
Comment 1 Mauricio Salatino 2013-06-24 11:06:55 EDT
I don't know how to reproduce the issue. Can you make sure that you have the correct MSSQL drivers for that database version? For this case I would recommend to see if the tests works at least with one version of MS SQL
Comment 2 Jiri Svitak 2013-06-25 03:20:29 EDT
Hi,
yes, I am sure that I use correct drivers. Other jBPM modules besides human-task work the same drivers fine, see the whole db matrix:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix/

Have you looked at the Jenkins job results? Have you analyzed the stack traces? Please open the the attached links to Jenkins.

If the available logs and resources are insufficient, you can reproduce the problem again - either configure your local test suite to use MSSQL or use Jenkins job:
https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/droolsjbpm-persistence-db-single/
You can also look how this 'single' job is executed and use its configuration Groovy script to run the job on local computer.

Please, do not ignore these bugs and set them to MODIFIED status only if the issue is resolved. Thanks.
Comment 4 Jiri Svitak 2013-08-08 12:12:44 EDT
Verified in 6.0.x product branch:

https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Drools%20jBPM/view/All/job/jbpm-persistence-db-matrix-6.0.x/DATABASE=mssql2008R2,MODULES=jbpm-human-task%2Fjbpm-human-task-core,jdk=java16_default,label_exp=RHEL5||RHEL6/5/

Cannot set the mandatory target milestone, because:
1.) there are no libraries of the product, which the verification can be done against
2.) the job is configured to run continuously against 6.0.x product branch

(Using ER1 for this.)
Comment 8 Jiri Svitak 2014-01-03 12:23:45 EST
commit in 6.0.x branch:
https://github.com/droolsjbpm/jbpm/commit/9b274ffa840ad0e56fb552b1f6384a9f9627e260
Comment 9 Lukáš Petrovický 2014-02-07 11:15:13 EST
This BZ has been part of the 6.0.0 stream.

Note You need to log in before you can comment on or make changes to this bug.