Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 972689 - neutron doesn't remove namespace after removing router same for network
neutron doesn't remove namespace after removing router same for network
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: Upstream M3
: 4.0
Assigned To: Maru Newby
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 08:09 EDT by Ofer Blaut
Modified: 2016-04-26 12:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 04:44:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (2.62 KB, text/plain)
2013-06-10 08:09 EDT, Ofer Blaut
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1250366 None None None Never

  None (edit)
Description Ofer Blaut 2013-06-10 08:09:23 EDT
Created attachment 759164 [details]
logs

Description of problem:
quantum doesn't remove namespace after removing router

Upon router create netns is created , when router is removed  netns is not being removed.

Since netns name reflect router ID, the netns  will not be used again

See attached log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.create router and add interface 
2.check netns list on the L3 host
3.delete interface from router and remove router 
4.check netns list on the L3 host , qrouter still there 
I didn't check if it is same case with network created  

Actual results:


Expected results:


Additional info:
Comment 1 Ofer Blaut 2013-06-10 08:32:25 EDT
I tested it for network and it is the same issue

network and subnet create qdhcp-<NET-UUID> netns.

After removing the subnet and network , the netns is not removed
Comment 8 Rami Vaknin 2013-11-12 04:42:19 EST
Still reproduces in rhos 4.0 on rhel 6.5 with 2013-11-08.1 puddle, reporting this bug upstream.
Comment 9 Rami Vaknin 2013-11-12 04:44:19 EST
Closing this one per oblaut request.

Note You need to log in before you can comment on or make changes to this bug.