Bug 972712 - SELinux is preventing java from 'execute' accesses on the file /home/kevin.below/.juniper_networks/network_connect/libncui.so.
SELinux is preventing java from 'execute' accesses on the file /home/kevin.be...
Status: CLOSED DUPLICATE of bug 885265
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f5ffde2f517878866d3505f5850...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 08:57 EDT by Kevin Below
Modified: 2013-06-12 05:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 05:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Below 2013-06-10 08:57:10 EDT
Description of problem:
Running java in Firefox.  
SELinux is preventing java from 'execute' accesses on the file /home/kevin.below/.juniper_networks/network_connect/libncui.so.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that java should be allowed execute access on the libncui.so file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/kevin.below/.juniper_networks/network_connec
                              t/libncui.so [ file ]
Source                        java
Source Path                   java
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-169.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.13-100.fc17.i686 #1 SMP Mon
                              May 13 13:51:09 UTC 2013 i686 i686
Alert Count                   4
First Seen                    2013-06-10 08:52:58 EDT
Last Seen                     2013-06-10 08:53:35 EDT
Local ID                      fd8f5e45-0567-400e-843f-e6fbdc39f781

Raw Audit Messages
type=AVC msg=audit(1370868815.98:93): avc:  denied  { execute } for  pid=2361 comm="java" path="/home/kevin.below/.juniper_networks/network_connect/libncui.so" dev="dm-2" ino=1179899 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


Hash: java,mozilla_plugin_t,user_home_t,file,execute

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file execute;

audit2allow -R

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_t:file execute;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.i686
type:           libreport
Comment 1 Miroslav Grepl 2013-06-12 05:26:55 EDT

*** This bug has been marked as a duplicate of bug 885265 ***

Note You need to log in before you can comment on or make changes to this bug.