Bug 972724 - pvs does not respect cluster locking as vgs/pvs do
pvs does not respect cluster locking as vgs/pvs do
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 09:19 EDT by Fabio Massimo Di Nitto
Modified: 2014-04-23 05:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 05:27:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2013-06-10 09:19:24 EDT
Description of problem:

In a cluster, with locking_type set to 3, start clvmd on all nodes, shutdown clvmd on one node:

pvs will fail to scan devices because it cannot obtain cluster locking.

vgs/lvs will instead report the error (correctly) and then provide the information.

Behavior should be consistent across all tools.
Comment 2 RHEL Product and Program Management 2014-03-22 02:46:41 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Peter Rajnoha 2014-04-23 05:27:31 EDT
Seems this no longer an issue:

[root@rhel7-b ~]# pvs
  PV         VG   Fmt  Attr PSize   PFree  
  /dev/sda   vg   lvm2 a--  124.00m 120.00m
  /dev/vda2  rhel lvm2 a--    9.51g      0 


[root@rhel7-c ~]# pvs
  connect() failed on local socket: No such file or directory
  Internal cluster locking initialisation failed.
  WARNING: Falling back to local file-based locking.
  Volume Groups with the clustered attribute will be inaccessible.
  Skipping clustered volume group vg
  Skipping volume group vg
  PV         VG   Fmt  Attr PSize PFree
  /dev/vda2  rhel lvm2 a--  9.51g    0

Note You need to log in before you can comment on or make changes to this bug.