Bug 972745 - Add delete-this-file feature support to the engine
Add delete-this-file feature support to the engine
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.2
Assigned To: Frantisek Kobzik
Jiri Belka
virt
: Improvement, ZStream
Depends On: 965179
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 10:05 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:07 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
virt-viewer now deletes SPICE and VNC descriptors after reading them as there is no need for the descriptor to exist on the disk after the session has been invoked.
Story Points: ---
Clone Of: 965179
Environment:
Last Closed: 2013-08-13 09:07:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Idith Tal-Kohen 2013-06-10 10:05:45 EDT
+++ This bug was initially created as a clone of Bug #965179 +++

Description of problem:
This feature adds an extra line to SPICE and VNC descriptors that tells virt-viewer to delete the descriptor after reading it. There is no need for the descriptor to exist on the disk after the session is invoked.

--- Additional comment from Michal Skrivanek on 2013-05-21 04:09:38 EDT ---

usability enhancement to better support upstream virt-viewer with MIME opening of console. Otherwise on every open in e.g. Chrome the MIME file gets downloaded and kept forever in user's Downloads directory

--- Additional comment from Michal Skrivanek on 2013-05-27 07:47:57 EDT ---

merged to master:
http://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=f81049b2ada7ae4676bffb7cb05c9e795aead3b6
Comment 3 Jiri Belka 2013-07-29 05:48:09 EDT
ok, sf19. console.vv is deleted after every invocation by remote-viewer.
Comment 4 errata-xmlrpc 2013-08-13 09:07:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1149.html

Note You need to log in before you can comment on or make changes to this bug.