Bug 972753 - PKCS12Export fails on Fedora 19
Summary: PKCS12Export fails on Fedora 19
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: Tools - Java
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 14:16 UTC by Ana Krivokapic
Modified: 2015-01-04 23:52 UTC (History)
7 users (show)

Fixed In Version: pki-tools-10.0.3-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-17 00:09:39 UTC


Attachments (Terms of Use)

Description Ana Krivokapic 2013-06-10 14:16:51 UTC
Description of problem:
On a fully updated F19 machine, PKCS12Export fails with exceptions:

[akrivoka@vm-149 ~]$ PKCS12Export 
Exception in thread "main" java.lang.NoClassDefFoundError: org/mozilla/jss/util/PasswordCallback
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2451)
	at java.lang.Class.getMethod0(Class.java:2694)
	at java.lang.Class.getMethod(Class.java:1622)
	at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
Caused by: java.lang.ClassNotFoundException: org.mozilla.jss.util.PasswordCallback
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
	... 6 more


Version-Release number of selected component (if applicable):
[akrivoka@vm-149 ~]$ rpm -qa | grep ^pki-*
pki-base-10.0.3-1.fc19.noarch
pki-tools-10.0.3-1.fc19.x86_64
pki-ca-10.0.3-1.fc19.noarch
pki-server-10.0.3-1.fc19.noar


How reproducible:
Always


Steps to Reproduce:
1. yum update
2. PKCS12Export


Actual results:
Command fails with exceptions even when run with no arguments.


Expected results:
Command should succeed.


Additional info:

Comment 1 Nathan Kinder 2013-06-10 15:06:16 UTC
Upstream ticket:
https://fedorahosted.org/pki/ticket/646

Comment 2 Nathan Kinder 2013-06-17 00:09:39 UTC
This is fixed in the pki-*-10.0.3-2 packages.  Please grab the latest packages from the F19 updates-testing repo and provide karma if they work for you.


Note You need to log in before you can comment on or make changes to this bug.