Bug 972770 - tracker-store: libtracker-data: Guard against failure to open the database
tracker-store: libtracker-data: Guard against failure to open the database
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tracker (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
abrt_hash:51045ca5f829659828ed41d1b96...
:
: 956452 1014288 1018406 1031443 1036404 1095871 1115182 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 10:41 EDT by Troy
Modified: 2014-10-13 10:27 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-13 10:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (20.46 KB, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: core_backtrace (1.32 KB, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: dso_list (2.75 KB, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: environ (1.28 KB, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-10 10:41 EDT, Troy
no flags Details
File: maps (15.56 KB, text/plain)
2013-06-10 10:42 EDT, Troy
no flags Details
File: open_fds (1.03 KB, text/plain)
2013-06-10 10:42 EDT, Troy
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-06-10 10:42 EDT, Troy
no flags Details
File: var_log_messages (16.76 KB, text/plain)
2013-06-10 10:42 EDT, Troy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 738450 None None None Never

  None (edit)
Description Troy 2013-06-10 10:41:40 EDT
Description of problem:
I have a partitioned drive. I went to the favorits, clicked on the file cabnet>Documnets. I then opened my backup partition in a new window and went to docunments in there - made the two document folders the same after transfers, deleting old stuff, etc. Unmounted ther back partition. Closed the Documents windown. Clicked on the Documents ico in the favorites bar and it crashed.

Version-Release number of selected component:
tracker-0.16.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-store
crash_function: tracker_db_statement_start_sparql_cursor
executable:     /usr/libexec/tracker-store
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #0 tracker_db_statement_start_sparql_cursor at tracker-db-interface-sqlite.c:2235
 #1 tracker_sparql_query_exec_sql_cursor at /home/martyn/Source/tracker/src/libtracker-data/tracker-sparql-query.vala:534
 #2 tracker_sparql_query_execute_cursor at /home/martyn/Source/tracker/src/libtracker-data/tracker-sparql-query.vala:553
 #3 tracker_data_query_sparql_cursor at tracker-data-query.c:143
 #4 tracker_store_pool_dispatch_cb at /home/martyn/Source/tracker/src/tracker-store/tracker-store.vala:213
 #5 _tracker_store_pool_dispatch_cb_gfunc at /home/martyn/Source/tracker/src/tracker-store/tracker-store.vala:309
 #7 g_thread_proxy at gthread.c:798
Comment 1 Troy 2013-06-10 10:41:44 EDT
Created attachment 759215 [details]
File: backtrace
Comment 2 Troy 2013-06-10 10:41:47 EDT
Created attachment 759216 [details]
File: cgroup
Comment 3 Troy 2013-06-10 10:41:50 EDT
Created attachment 759217 [details]
File: core_backtrace
Comment 4 Troy 2013-06-10 10:41:53 EDT
Created attachment 759218 [details]
File: dso_list
Comment 5 Troy 2013-06-10 10:41:56 EDT
Created attachment 759219 [details]
File: environ
Comment 6 Troy 2013-06-10 10:41:59 EDT
Created attachment 759220 [details]
File: limits
Comment 7 Troy 2013-06-10 10:42:02 EDT
Created attachment 759221 [details]
File: maps
Comment 8 Troy 2013-06-10 10:42:04 EDT
Created attachment 759222 [details]
File: open_fds
Comment 9 Troy 2013-06-10 10:42:07 EDT
Created attachment 759223 [details]
File: proc_pid_status
Comment 10 Troy 2013-06-10 10:42:10 EDT
Created attachment 759224 [details]
File: var_log_messages
Comment 11 Christopher Beland 2013-09-30 20:46:51 EDT
I started the Character Map. Not sure if this is from the startup or the finding it in gnome-shell.

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-store
crash_function: tracker_db_statement_start_sparql_cursor
executable:     /usr/libexec/tracker-store
kernel:         3.11.1-200.fc19.x86_64
package:        tracker-0.16.2-1.fc19
reason:         Process /usr/libexec/tracker-store was killed by signal 11 (SIGSEGV)
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 12 Joachim Frieben 2013-10-31 02:03:05 EDT
Issue also affects tracker-0.16.2-4.fc20.
Comment 13 Nishanth 2013-12-02 11:49:35 EST
I was trying to install Panel-Docklet v14 .
When i installed that dock from Gnome extension website a messages was shown regarding this.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/tracker-store
crash_function: tracker_db_statement_start_sparql_cursor
executable:     /usr/libexec/tracker-store
kernel:         3.9.5-301.fc19.x86_64
package:        tracker-0.16.1-3.fc19
reason:         Process /usr/libexec/tracker-store was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
Comment 14 Fedora Admin XMLRPC Client 2014-07-26 13:11:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Fedora Admin XMLRPC Client 2014-07-27 02:33:06 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Debarshi Ray 2014-10-02 05:13:40 EDT
*** Bug 1095871 has been marked as a duplicate of this bug. ***
Comment 17 Debarshi Ray 2014-10-02 05:13:53 EDT
*** Bug 1115182 has been marked as a duplicate of this bug. ***
Comment 18 Debarshi Ray 2014-10-02 05:14:34 EDT
Seen this in versions newer than F19.
Comment 19 Debarshi Ray 2014-10-02 05:15:58 EDT
*** Bug 1014288 has been marked as a duplicate of this bug. ***
Comment 20 Debarshi Ray 2014-10-02 05:16:00 EDT
*** Bug 1018406 has been marked as a duplicate of this bug. ***
Comment 21 Debarshi Ray 2014-10-10 08:54:01 EDT
*** Bug 956452 has been marked as a duplicate of this bug. ***
Comment 22 Debarshi Ray 2014-10-10 08:54:05 EDT
*** Bug 1036404 has been marked as a duplicate of this bug. ***
Comment 23 Debarshi Ray 2014-10-13 06:31:32 EDT
*** Bug 1031443 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.