Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 972852 - Failed content view definition publish/refres can not always be re-tried
Failed content view definition publish/refres can not always be re-tried
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: Unused
Assigned To: Justin Sherrill
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 12:06 EDT by Og Maciel
Modified: 2014-04-24 13:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:10:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-06-10 12:06:35 EDT
Description of problem:

Please see https://github.com/Katello/katello/issues/2448 for the original issue

Sometimes attempting to refresh and failed published view will fail with an exception. I believe that the repo has been cloned, but for some reason we don't realize it has been.

Validation failed: Pulp has already been
taken
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/validations.rb:56:in save!'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/attribute_methods/dirty.rb:33:insave!'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/transactions.rb:264:in block in save!'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/transactions.rb:313:inblock in with_tra
nsaction_returning_status'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/connection_adapters/abstract/database_sta
tements.rb:192:in transaction'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/transactions.rb:208:intransaction'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/transactions.rb:311:in with_transaction_
returning_status'
/home/jlsherri/.rvm/gems/ruby-1.9.3-p374@katello/gems/activerecord-3.2.13/lib/active_record/transactions.rb:264:insave!'
/home/jlsherri/git/katello/app/lib/lazy_accessor.rb:108:in save!'
/home/jlsherri/git/katello/app/models/repository.rb:267:increate_clone'
/home/jlsherri/git/katello/app/models/content_view_version.rb:137:in block in refresh_repos'
/home/jlsherri/git/katello/app/models/content_view_version.rb:131:ineach'
/home/jlsherri/git/katello/app/models/content_view_version.rb:131:in refresh_repos'
/home/jlsherri/git/katello/app/models/content_view_version.rb:82:inrefresh_version'
/home/jlsherri/git/katello/app/models/async_operation.rb:58:in `perform'


Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10005-1.noarch
* foreman-compute-1.1.10005-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10005-1.noarch
* foreman-postgresql-1.1.10005-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-11.el6sat.noarch
* katello-all-1.4.2-11.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-11.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-11.el6sat.noarch
* katello-glue-candlepin-1.4.2-11.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-11.el6sat.noarch
* katello-glue-pulp-1.4.2-11.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. You'll need a failed "publish" of a content view
2. Attempt to re-generate it
3.

Actual results:

Notification in the web UI says: Pulp has been taken

Expected results:


Additional info:
Comment 2 Mike McCune 2013-06-20 00:45:44 EDT
This is a side effect of timeouts we are experiencing, which we are working to address in MDP1.

We can leave this open as we track the bug addressing this:

https://bugzilla.redhat.com/show_bug.cgi?id=960278

in the longer term we need to be able to recover from a timeout but need to fix that first.
Comment 3 Og Maciel 2013-06-21 12:37:46 EDT
Changed to ON_QA since dependency BZ is also ready for testing
Comment 4 Og Maciel 2013-06-22 12:55:46 EDT
Even though the other BZ mentioned here has been fixed (https://bugzilla.redhat.com/show_bug.cgi?id=960278), we still don't have a proper fix for timeouts. Asking for 6.0.2 fix and moving it back to ASSIGNED.
Comment 5 Mike McCune 2013-06-22 13:00:09 EDT
DONE
Comment 7 Justin Sherrill 2013-10-23 15:25:29 EDT
I've tried to reproduce this by setting the pulp timeout to 10, but i think we fixed this too well reproduce very easily.  And i don't think there is much i can do unless we can reproduce.
Comment 8 Justin Sherrill 2013-10-23 15:52:29 EDT
I also tried while syncing 2 large repos while publishing a content view with a very large repo in it (with the timeout set to 10).  In every case things worked as expected.
Comment 9 Justin Sherrill 2013-10-23 16:14:57 EDT
Moving to ON_QA, if you can get me a reproducer, that would be great.
Comment 10 Og Maciel 2013-10-28 11:37:15 EDT
Cannot reproduce it anymore. Will re-open it if we ever get a reliable reproducer.

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-20.el6sat.noarch
* foreman-compute-1.3.0-20.el6sat.noarch
* foreman-libvirt-1.3.0-20.el6sat.noarch
* foreman-postgresql-1.3.0-20.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-49.el6sat.noarch
* katello-all-1.4.6-49.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-27.el6sat.noarch
* katello-cli-common-1.4.3-27.el6sat.noarch
* katello-common-1.4.6-49.el6sat.noarch
* katello-configure-1.4.7-7.el6sat.noarch
* katello-configure-foreman-1.4.7-7.el6sat.noarch
* katello-foreman-all-1.4.6-49.el6sat.noarch
* katello-glue-candlepin-1.4.6-49.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-49.el6sat.noarch
* katello-glue-pulp-1.4.6-49.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.24.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.24.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.24.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.24.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.24.beta.el6sat.noarch
* pulp-server-2.3.0-0.24.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.23-2.el6sat.noarch
* signo-katello-0.0.23-2.el6sat.noarch
Comment 13 Bryan Kearney 2014-04-24 13:10:05 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 14 Bryan Kearney 2014-04-24 13:11:25 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.