Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 972862 - cppunit fails to detect GCC C++ ABI name demangling support
cppunit fails to detect GCC C++ ABI name demangling support
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cppunit (Show other bugs)
6.4
All Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dodji Seketeli
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 12:36 EDT by Vasil Velichkov
Modified: 2015-12-11 09:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 09:39:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 650033 None None None Never

  None (edit)
Description Vasil Velichkov 2013-06-10 12:36:23 EDT
Description of problem:

cppunit fails to detect GCC C++ ABI name demangling and as a result produce strange class names.

Version-Release number of selected component (if applicable):

$ rpm -q cppunit gcc
cppunit-1.12.1-3.1.el6.x86_64
gcc-4.4.7-3.el6.x86_64

How reproducible:


Steps to Reproduce:
1. fedpkg clone cppunit --anonymous
2. fedpkg compile 
3. vim cppunit-1.12.1/config.log

Actual results:

configure:21050: checking whether the compiler supports GCC C++ ABI name demangling
configure:21099: g++ -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic  conftest.cpp >&5
conftest.cpp: In function 'int main()':
conftest.cpp:42: error: 'free' was not declared in this scope

$ cat cppunit-1.12.1/config/config.h | grep DEMANGLE
/* #undef HAVE_GCC_ABI_DEMANGLE */

Expected results:

configure:21276: checking whether the compiler supports GCC C++ ABI name demangling 
configure:21326: g++ -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic  conftest.cpp >&5 
configure:21333: $? = 0 

$ cat cppunit-1.12.1/config/config.h | grep DEMANGLE
#define HAVE_GCC_ABI_DEMANGLE 1

Additional info:

http://sourceforge.net/p/cppunit/bugs/198/

http://sourceforge.net/p/cppunit/bugs/_discuss/thread/314b3edd/874d/attachment/cppunit-1.12.0-add_configure_missing_include.patch

This patch seems to resolve this problem.
Comment 2 RHEL Product and Program Management 2013-10-13 19:29:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Matt Newsome 2015-12-11 09:39:08 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux. We've carefully evaluated the request, but are unable to include it in a future release. To request that Red Hat re-consider this request, please re-open the bugzilla via appropriate support channels and provide additional business and/or technical details about its importance to you.

Note You need to log in before you can comment on or make changes to this bug.