Bug 972869 - headphone port not working in kernel higher then 3.7
headphone port not working in kernel higher then 3.7
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 13:10 EDT by Rui Gomes
Modified: 2014-06-18 09:59 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 09:59:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Gomes 2013-06-10 13:10:01 EDT
Description of problem:

Regardless of the port set(I try set the port using pacmd and phonon) the sound always play just in the speakers never in the headphones.

Additional info:

Im using full updated fedora19 installed using fedup from fedora17 and the headphones did work on the fedora17.
I have two headphone jacks in the laptop a alienware m14x r2.

I been playing around with the default configuration for the analog-output-headphone and no luck to get any sound on the headphones.

System information:

Alsa:

alsa-utils-1.0.27.1-1.fc19.x86_64
alsa-oss-1.0.17-8.fc19.x86_64
alsa-oss-libs-1.0.17-8.fc19.i686
alsa-plugins-oss-1.0.27-1.fc19.i686
alsa-plugins-pulseaudio-1.0.27-1.fc19.x86_64
alsa-lib-1.0.27.1-2.fc19.i686
alsa-plugins-jack-1.0.27-1.fc19.x86_64
alsa-tools-firmware-1.0.27-2.fc19.x86_64
alsa-plugins-pulseaudio-1.0.27-1.fc19.i686
alsa-firmware-1.0.27-1.fc19.noarch
alsa-lib-1.0.27.1-2.fc19.x86_64

Pulse:

pulseaudio-utils-3.0-10.fc19.x86_64
pulseaudio-equalizer-2.7-11.fc19.noarch
pulseaudio-module-x11-3.0-10.fc19.x86_64
pulseaudio-module-jack-3.0-10.fc19.x86_64
pulseaudio-3.0-10.fc19.x86_64
alsa-plugins-pulseaudio-1.0.27-1.fc19.x86_64
pulseaudio-libs-glib2-3.0-10.fc19.i686
pulseaudio-module-zeroconf-3.0-10.fc19.x86_64
xmms-pulse-0.9.4-12.fc19.x86_64
pulseaudio-esound-compat-3.0-10.fc19.x86_64
pulseaudio-libs-3.0-10.fc19.x86_64
pulseaudio-module-gconf-3.0-10.fc19.x86_64
pulseaudio-libs-3.0-10.fc19.i686
alsa-plugins-pulseaudio-1.0.27-1.fc19.i686
pulseaudio-libs-glib2-3.0-10.fc19.x86_64

Kernel:

Linux m14x 3.9.4-301.fc19.x86_64 #1 SMP Tue Jun 4 00:30:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Sinks:

>>> list-sinks
1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY FLAT_VOLUME DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE 
        priority: 9959
        volume: 0: 100% 1: 100%
                0: 0.00 dB 1: 0.00 dB
                balance 0.00
        base volume:  71%
                     -9.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 0
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1837.50 ms
        card: 0 <alsa_card.pci-0000_00_1b.0>
        module: 4
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "CA0132 Analog"
                alsa.id = "CA0132 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xd2710000 irq 46"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "1e20"
                device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Intel PantherPoint HDMI"
                alsa.components = "HDA:11020011,10280552,00100918 HDA:80862806,10280552,00100000"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 100, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
        active port: <analog-output-headphones>

Cards:

>>> list-cards
1 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_00_1b.0>
        driver: <module-alsa-card.c>
        owner module: 4
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xd2710000 irq 46"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "1e20"
                device.product.name = "7 Series/C210 Series Chipset Family High Definition Audio Controller"
                device.form_factor = "internal"
                device.string = "0"
                device.description = "Built-in Audio"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 60)
                input:iec958-stereo: Digital Stereo (IEC958) Input (priority 55)
                output:analog-stereo: Analog Stereo Output (priority 6000)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060)
                output:analog-stereo+input:iec958-stereo: Analog Stereo Output + Digital Stereo (IEC958) Input (priority 6055)
                output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500)
                output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5560)
                output:iec958-stereo+input:iec958-stereo: Digital Stereo Duplex (IEC958) (priority 5555)
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400)
                output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5460)
                output:hdmi-stereo+input:iec958-stereo: Digital Stereo (HDMI) Output + Digital Stereo (IEC958) Input (priority 5455)
                output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300)
                output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Output + Analog Stereo Input (priority 360)
                output:hdmi-surround+input:iec958-stereo: Digital Surround 5.1 (HDMI) Output + Digital Stereo (IEC958) Input (priority 355)
                off: Off (priority 0)
        active profile: <output:analog-stereo>
        sinks:
                alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Built-in Audio Analog Stereo
        sources:
                alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Built-in Audio Analog Stereo
        ports:
                analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
                        properties:

                iec958-stereo-input: Digital Input (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

                analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-speakers"
                analog-output-headphones: Headphones (priority 100, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
Comment 1 Mikkel Lauritsen 2013-06-21 15:59:37 EDT
Is this the same problem as I've experienced in Bug 968187 ?
Comment 2 Rui Gomes 2013-06-21 17:36:57 EDT
Hi,

Yes the bug seems to be exact the same, I can see the headphones are plug-in but does not matter how much I play with the pulse configuration I can't get none of my headphone plugs to output nothing, im currently using the fedora19 with kernel 3.9.6-301.fc19.x86_64 still no joy :(
Comment 3 Kathel D. 2013-09-30 11:09:24 EDT
Hello,

I have exactly the same problem on my Alienware m17x, using Fedora 19 and the current default configuration (Pulseaudio 3.0 and kernel 3.11.1-200.fc19.x86_64).

Any news about this bug?
Comment 4 Rui Gomes 2013-09-30 20:00:47 EDT
Hi Kathel 

I give this another go and waste a few more hours in this, I recompile the kernel with some audio patch, I went all the way up to the 3.12rc3 and still no luck, and I tried all kind of combos, including passing the option.

options snd-hda-intel model=dell-eq and alienware

I would truly like to see this fixed, but I still not sure where the bug is pulseaudio/kernel ?
Comment 5 Kathel D. 2013-10-01 05:18:45 EDT
Using alsamixer in console, I got my headphones working:

By default I had in alsamixer:
Card: Pulseaudio
Chipset: Pulseaudio

Using F6 in order to change card, there is two options:
- (default)
0 HDA Intel PCM

I select 0 HDA Intel PCM, and then the sound goes through my headphones. I must repeat the operation each time I want sound in my headphones. 

I have this line in /etc/modprobe.d/alsa-base.conf:
options snd-hda-intel model=dell-m6-amic
(I doubt this changes anything)

I guess the problem comes from the interaction between alsa and pulseaudio, but I am no expert into this...
Comment 6 Rui Gomes 2013-10-01 07:50:35 EDT
Hi Kathel, 

Thanks for the advice, but I got the headphones to work by going back a few releases in the kernel. I'm in position to say is a KERNEL bug, I got the vanilla 3.4 kernel soon I boot it the headphones worked perfectly no need to do any extra steps. I guess this bug should be moved from pulseaudio and assign to Kernel.
Comment 7 Justin M. Forbes 2014-01-03 17:11:10 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 8 Rui Gomes 2014-01-03 17:40:16 EST
Hello,

Yes I'm still experiencing this problem, at the moment I have the kernel from the rawhide installed 3.13.0-0.rc5.git0.2.fc21.x86_64, 
the alsa version:

sudo yum info alsa-lib.x86_64
Installed Packages
Name        : alsa-lib
Arch        : x86_64
Version     : 1.0.27.2
Release     : 2.fc20
Size        : 1.2 M
Repo        : installed
From repo   : rawhide
Summary     : The Advanced Linux Sound Architecture (ALSA) library
URL         : http://www.alsa-project.org/
License     : LGPLv2+
Description : The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI
            : functionality to the Linux operating system.
            : 
            : This package includes the ALSA runtime libraries to simplify application
            : programming and provide higher level functionality as well as support for
            : the older OSS API, providing binary compatibility for most OSS programs.

And the output from the alsa info script can be found at:

http://www.alsa-project.org/db/?f=16460a19015524214e6ea4f491b369fc9ea3b02c
Comment 9 Kathel D. 2014-01-04 05:13:10 EST
Hello,

The problem seems to be solved for me with this update on Fedora 19 with kernel 3.12.6-200.fc19.x86_64 and alsa-lib Version 1.0.27.2, Release 1.fc19
Comment 10 Rui Gomes 2014-01-12 04:00:34 EST
Hello Kathel,

That didn't work for me,

rgomes@m14x:~$ uname -r
3.12.6-200.fc19.x86_64

rgomes@m14x:~$ sudo yum info alsa-lib
Name        : alsa-lib
Arch        : i686
Version     : 1.0.27.2
Release     : 2.fc20
Size        : 1.2 M
Repo        : installed
From repo   : rawhide
Summary     : The Advanced Linux Sound Architecture (ALSA) library
URL         : http://www.alsa-project.org/
License     : LGPLv2+

And still no sound on the headphones
Comment 11 mortheres 2014-01-23 10:16:22 EST
Hi Rui,

I had the same problem as you using kernel 3.12.8-200.fc19.x86_64 and alsa-lib-1.0.27.2-1 under fedora 19 but I had to go in alsamixer (as Kathel did) to make it works.

This is what I did:
- Launch alsamixer
- Change sound card to select 0 HDA Intel PCM (using F6 key)
- Unmute "HP/Speaker Auto Detect" control (which was displayed as 'MM') using the M key. Now it is displayed as '00'.
- Try to plug and unplug the headphones and it works like a charm :D :D

I use an Alienware M17x.

Kind regards,

--
Guillaume
Comment 12 Justin M. Forbes 2014-02-24 09:02:21 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.13.4-200.fc20.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 13 Mikkel Lauritsen 2014-02-25 06:36:16 EST
As mentioned in bug 968187 this has been working for me for a while, the current kernel included.
Comment 14 Justin M. Forbes 2014-05-21 15:40:34 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.14.4-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.