Bug 9729 - Minor bug (?) in the file /etc/rc.d/init.d/functions
Summary: Minor bug (?) in the file /etc/rc.d/init.d/functions
Status: CLOSED DUPLICATE of bug 9727
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-23 22:21 UTC by david
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 23:28:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description david 2000-02-23 22:21:24 UTC
The mechanism used to detect if a daemon is still running is incompatible
with sendmail.  When sendmail has any number of active connections, the
command '/etc/rc.d/init.d/sendmail restart' cannot be used to restart
sendmail, since the 'daemon' function thinks that sendmail is still
running.

The problem is one of basic logic... when a deamon is stopped, its
/var/run/xxx.pid file is unlinked.  Without that file however, you don't
know which process is the parent and which are the children.

I'm not sure if this is a 'bug' or if there is simply no way to do this
'correctly', but whatever the case, it is annoying. :-)

Comment 1 Bill Nottingham 2000-02-23 23:28:59 UTC
*** This bug has been marked as a duplicate of 9727 ***


Note You need to log in before you can comment on or make changes to this bug.