Bug 972904 - mongodb might not work properly on Fedora with boost > 1.49
Summary: mongodb might not work properly on Fedora with boost > 1.49
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mongodb (Show other bugs)
(Show other bugs)
Version: 18
Hardware: Unspecified Linux
unspecified
medium
Target Milestone: ---
Assignee: Nathaniel McCallum
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-10 19:04 UTC by Johan Hedin
Modified: 2013-09-24 00:32 UTC (History)
5 users (show)

Fixed In Version: mongodb-2.4.6-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 00:32:14 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johan Hedin 2013-06-10 19:04:06 UTC
This is not a definitive bug, just a hint that there might be issues regarding mongodb with boost 1.50 that is in Fedora 18 and boost 1.53 that is in fedora 19.

According to this mongodb JIRA: https://jira.mongodb.org/browse/SERVER-8994 there could be thread issues with mongodb when boost > 1.49.

Comment 1 Troy Dawson 2013-06-10 20:07:15 UTC
Interesting.
We've been using mongodb 2.2.x quite successfully on Fedora 18 and Fedora 19.  But I've been having boost problems with mongodb 2.4.x.  I will have to double check to see if that might be the problem.

Comment 2 Johan Hedin 2013-06-10 20:21:43 UTC
What problems have you seen with 2.4.x regarding boost?

I have successfully rebuild the Fedora/EPEL RPM:s with mongodb 2.4.3 by picking a couple of patches that where floating around in JIRA:s regarding boost and other stuff. Compile and works on both CentOS 6.4 and Fedora 17 but not tried on F18 or F19.

Comment 3 Troy Dawson 2013-06-10 21:25:45 UTC
It's been so long since I worked with it (2 1/2 months) that I don't remember.  I just remember going through the options and it would build correctly without the system boost, but wouldn't build with the system boost.
You wouldn't have the src.rpm for your 2.4.x package that worked would you?  And/or the links to the patches you found?

Comment 4 Johan Hedin 2013-06-10 21:51:23 UTC
Sure, I'm more than happy to share the src.rpm. My plan was to push the fixes to Fedora/EPEL anyway but I have not had the time yet.

I will update my build with mongodb 2.4.4 that was released last week so that I can drop some patches that are now included upstream.

It will probably take me a couple of days, but I'll get back to you when its done.

Comment 5 Johan Hedin 2013-06-24 20:07:13 UTC
Took a bit longer than I thought to get my rpm in a releasable form. Had to redo a couple of things but it is near now.

I will create a new bug regarding upgrade to 2.4 so that we can continue that issue there.

Comment 6 Tim Hawkins 2013-06-26 01:53:46 UTC
Im also trying to get 2.4.4 runing on 19beta, and im running into severe boost issues. From both 10gen packages and source compile. 

Is there any progress on available rpm's for this?

Comment 7 Johan Hedin 2013-06-30 14:20:21 UTC
Troy and Tim, see bug #979784

Comment 8 Fedora Update System 2013-09-19 20:57:10 UTC
mongodb-2.4.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mongodb-2.4.6-1.fc19

Comment 9 Fedora Update System 2013-09-21 08:28:03 UTC
Package mongodb-2.4.6-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mongodb-2.4.6-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17283/mongodb-2.4.6-1.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-09-24 00:32:14 UTC
mongodb-2.4.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.