Bug 97294 - hang on shutdown after unplugging mounted camera
hang on shutdown after unplugging mounted camera
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 14:41 EDT by Mark Finlay
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:07:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Finlay 2003-06-12 14:41:59 EDT
If I plug in my camera (Sony DCS-P31) kudzu adds an fstab entry,
then I can mount the camera in nautilus. (usbblockdev)

If I unplug the camera or it runs out of battery or whatever
before I've unmounted it, then kudzu removes the camera 
item from the fstab, but the system thinks that the 
camera is still mounted. But now because there is no
fstab entry i can't unmount as user. Then when I go
to shutdown the pc doens't get passed the unmounting stage.

I can umount manually with 'umount -f /mnt/camera' as
root as long as nautilus isn't running, I would of thought
that the init scripts would try this if they can't unmount..
Comment 1 Bill Nottingham 2005-09-23 16:07:00 EDT
Closing out bugs on older, no longer supported, releases. Apologies for any lack
of response.

Please test this bug on a current release, such as Fedora Core 4. If it persists
there, please file a new bug.

Note that this is handled through the 'hal' component in current releases.

Note You need to log in before you can comment on or make changes to this bug.