Bug 972941 - Upgrade RESTEasy for EAP 6.2
Upgrade RESTEasy for EAP 6.2
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RESTEasy (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.2.0
Assigned To: Weinan Li
Petr Sakař
Depends On: 968049
  Show dependency treegraph
Reported: 2013-06-10 17:00 EDT by Kyle Lape
Modified: 2015-02-20 05:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-12-15 11:22:54 EST
Type: Component Upgrade
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kyle Lape 2013-06-10 17:00:10 EDT

Comment 1 Pavel Janousek 2013-06-12 04:46:04 EDT
There isn't new version of 2.3. branch in the community. The latest community version of RESTEasy (2.3.6) is included in EAP-6.1.0 already.

Which updated version of RESTEasy is subject of this BZ?
Comment 2 Kyle Lape 2013-06-12 22:23:29 EDT
We need an upgraded version to include the BZ this depends on (968049).  Do we need to get Bill to commit that fix to the 2.3 branch and make a release for it?
Comment 3 Pavel Janousek 2013-06-13 02:49:09 EDT
I'm not sure who should set a dev_ack. I think Wei Nan Li (weli@redhat.com) is the right person on productization side, but I'm not sure.

Branch 2.3. is in maintenance mode right now, I think Ron Sigal is the (primary) maintainer of it.

Bill is primary focused on JAX-RS 2.0 -> RESTEasy 3 branch/trunk.
Comment 4 Weinan Li 2013-06-14 04:47:43 EDT
Hi Kyle, could you please create a pull request to https://github.com/resteasy/Resteasy on Branch_2_3 so that Bill could check it and merge into the branch? I could also help to do the PR if you can provide the patch needed to be applied on Branch_2_3. Thanks!
Comment 7 Weinan Li 2013-08-08 10:29:01 EDT
Needs to upgrade to 2.3.7.Final
Comment 8 Weinan Li 2013-08-22 03:08:55 EDT
*** Bug 996918 has been marked as a duplicate of this bug. ***
Comment 14 Petr Sakař 2013-10-08 08:10:53 EDT
list of supported dependencies and their versions in EAP 6.2.0.ER5

Note You need to log in before you can comment on or make changes to this bug.