Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 972942 - org name changes do not propogate via sst into katello
Summary: org name changes do not propogate via sst into katello
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Subscription Asset Manager
Classification: Retired
Component: Splice
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: James Slagle
QA Contact: mkovacik
URL:
Whiteboard:
Depends On:
Blocks: sam13-tracker
TreeView+ depends on / blocked
 
Reported: 2013-06-10 21:04 UTC by Chris Duryee
Modified: 2013-10-01 10:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-01 10:55:45 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 0 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 14:43:14 UTC

Description Chris Duryee 2013-06-10 21:04:28 UTC
Description of problem: If a satellite's org name is changed, this change does not make it into SAM via spacewalk-splice-tool --spacewalk-sync.


Version-Release number of selected component (if applicable): 0.19


How reproducible: every time


Steps to Reproduce:
1. create an org in satellite, and perform a sync
2. change the org's name
3. sync again

Actual results: org name is not altered in SAM


Expected results: org name should be changed in SAM


Additional info: If an org label exists for the org in SAM, we don't do any further processing. We probably need to do an additional check to update the name if needed.

Comment 1 James Slagle 2013-06-19 12:09:21 UTC
commit 300cd8b5612996a23acdd9def04056d1f38c70ea to sst

Org name changes are now propagated from Satellite to SAM.  I also update the distributor name as well since the org name is part of the distributor name.

Comment 2 Vitaly Kuznetsov 2013-06-21 14:25:44 UTC
Verified in spacewalk-splice-tool-0.24-1.el6sam.x86_64

Comment 4 errata-xmlrpc 2013-10-01 10:55:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html


Note You need to log in before you can comment on or make changes to this bug.