Bug 972946 - perl-Net-SSH-Expect 1.09-6 Bad Directory Permissions
perl-Net-SSH-Expect 1.09-6 Bad Directory Permissions
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: perl-Net-SSH-Expect (Show other bugs)
el5
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Carl Thompson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 17:22 EDT by Mitch McCracken
Modified: 2013-09-14 20:56 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Net-SSH-Expect-1.09-14.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-14 15:04:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for perms in %files (990 bytes, patch)
2013-07-31 22:54 EDT, RJ Bergeron
no flags Details | Diff

  None (edit)
Description Mitch McCracken 2013-06-10 17:22:13 EDT
Description of problem:

Installing this latest version of Net::SSH::Expect causes some of our things to blow up.  Reason being:

$ ls -al /usr/lib/perl5/vendor_perl/5.8.8
…
drw-r--r--  8 root root  4096 May 15 04:02 Net

$ ls -al /usr/lib/perl5/vendor_perl/5.8.8/Net/SSH
total 0
?--------- ? ? ? ?            ? .
?--------- ? ? ? ?            ? ..
?--------- ? ? ? ?            ? Expect.pm
?--------- ? ? ? ?            ? Expect.pod
?--------- ? ? ? ?            ? Perl
?--------- ? ? ? ?            ? Perl.pm

within the spec file:

%defattr(644,root,root)

I believe this should be 755 instead.  The root user can see them just fine, but any non-root user won't be able to use any modules underneath the Net/ directory after you upgrade this module.


Version-Release number of selected component (if applicable):

1.09-6

How reproducible:

easily

Steps to Reproduce:
0. don't be a root user
1. sudo yum install perl-Net-SSH-Expect-1.09-6
2. perl -e "use Net::SSH::Expect" (as user other than root)

Actual results:

Can't locate Net/SSH/Expect.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at -e line 1.

Expected results:

(no errors)

Additional info:

This happens in both the i386 and x86_64 releases
Comment 1 RJ Bergeron 2013-07-31 22:54:37 EDT
Created attachment 781414 [details]
patch for perms in %files

Patch for %files specification of perl-Net-SSH-Expect.spec - uses perl_vendorlib (which is valid on stock EL5 hosts) and fixes directory permissions.
Comment 2 Carl Thompson 2013-08-27 19:36:47 EDT
What OS are you installing this on as I'm not seeing this issue on RHEL.

The patch file will not work because I can't use the standard macro for the directory.  It is matched at the top of the spec file based on what its being built for.
Comment 3 Fedora Update System 2013-08-28 11:16:21 EDT
perl-Net-SSH-Expect-1.09-14.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-Net-SSH-Expect-1.09-14.fc19
Comment 4 Fedora Update System 2013-08-28 11:16:31 EDT
perl-Net-SSH-Expect-1.09-7.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Net-SSH-Expect-1.09-7.el5
Comment 5 Fedora Update System 2013-08-28 11:16:40 EDT
perl-Net-SSH-Expect-1.09-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/perl-Net-SSH-Expect-1.09-13.fc18
Comment 6 Fedora Update System 2013-08-28 11:16:49 EDT
perl-Net-SSH-Expect-1.09-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Net-SSH-Expect-1.09-7.el6
Comment 7 Fedora Update System 2013-08-29 13:41:44 EDT
Package perl-Net-SSH-Expect-1.09-7.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing perl-Net-SSH-Expect-1.09-7.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11381/perl-Net-SSH-Expect-1.09-7.el5
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-09-14 15:04:43 EDT
perl-Net-SSH-Expect-1.09-7.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-09-14 15:05:09 EDT
perl-Net-SSH-Expect-1.09-7.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-09-14 20:50:34 EDT
perl-Net-SSH-Expect-1.09-13.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-09-14 20:56:51 EDT
perl-Net-SSH-Expect-1.09-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.